summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzdata/tzdata_2018f.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-10-22 15:05:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-07 21:34:08 +0000
commitd6ea55c28ad1345012785e4b620b4155f4de3efa (patch)
treef5a7979cc6df66fcabda39240e14fd3e1dadaa3e /meta/recipes-extended/tzdata/tzdata_2018f.bb
parent7522dfaeee8f7889a1ad367ecb638166933b9948 (diff)
downloadpoky-d6ea55c28ad1345012785e4b620b4155f4de3efa.tar.gz
tzdata: update to 2018f
Briefly: Volgograd moves from +03 to +04 on 2018-10-28. Fiji ends DST 2019-01-13, not 2019-01-20. Most of Chile changes DST dates, effective 2019-04-06. Changes to future timestamps Volgograd moves from +03 to +04 on 2018-10-28 at 02:00. (Thanks to Alexander Fetisov and Stepan Golosunov.) Fiji ends DST 2019-01-13 instead of the 2019-01-20 previously predicted. (Thanks to Raymond Kumar.) Adjust future predictions accordingly. Most of Chile will end DST on the first Saturday in April at 24:00 mainland time, and resume DST on the first Saturday in September at 24:00 mainland time. The changes are effective from 2019-04-06, and do not affect the Magallanes region modeled by America/Punta_Arenas. (Thanks to Juan Correa and Tim Parenti.) Adjust future predictions accordingly. Changes to past timestamps The 2018-05-05 North Korea 30-minute time zone change took place at 23:30 the previous day, not at 00:00 that day. China's 1988 spring-forward transition was on April 17, not April 10. Its DST transitions in 1986/91 were at 02:00, not 00:00. (Thanks to P Chan.) Fix several issues for Macau before 1992. Macau's pre-1904 LMT was off by 10 s. Macau switched to +08 in 1904 not 1912, and temporarily switched to +09/+10 during World War II. Macau observed DST in 1942/79, not 1961/80, and there were several errors for transition times and dates. (Thanks to P Chan.) The 1948-1951 fallback transitions in Japan were at 25:00 on September's second Saturday, not at 24:00. (Thanks to Phake Nick.) zic turns this into 01:00 on the day after September's second Saturday, which is the best that POSIX or C platforms can do. Incorporate 1940-1949 Asia/Shanghai DST transitions from a 2014 paper by Li Yu, replacing more-questionable data from Shanks. Changes to time zone abbreviations Use "PST" and "PDT" for Philippine time. (Thanks to Paul Goyette.) Changes to documentation New restrictions: A Rule name must start with a character that is neither an ASCII digit nor "-" nor "+", and an unquoted name should not use characters in the set "!$%&'()*,/:;<=>?@[\]^`{|}~". The latter restriction makes room for future extensions (a possibility noted by Tom Lane). tzfile.5 now documents what time types apply before the first and after the last transition, if any. Documentation now uses the spelling "timezone" for a TZ setting that determines timestamp history, and "time zone" for a geographic region currently sharing the same standard time. The name "TZif" is now used for the tz binary data format. tz-link.htm now mentions the A0 TimeZone Migration utilities. (Thanks to Aldrin Martoq for the link.) Changes to build procedure New 'make' target 'rearguard_tarballs' to build the rearguard tarball only. This is a convenience on platforms that lack lzip if you want to build the rearguard tarball. (Problem reported by Deborah Goldsmith.) tzdata.zi is now more stable from release to release. (Problem noted by Tom Lane.) It is also a bit shorter. tzdata.zi now can contain comment lines documenting configuration information, such as which data format was selected, which input files were used, and how leap seconds are treated. (Problems noted by Lester Caine and Brian Inglis.) If the Makefile defaults are used these comment lines are absent, for backward compatibility. A redistributor intending to alter its copy of the files should also append "-LABEL" to the 'version' file's first line, where "LABEL" identifies the redistributor's change. (From OE-Core rev: 9d786808fb9471eff46d95dd354f6254e468aa17) (From OE-Core rev: 834df7b26c12e4d164a50bcd07b194cb455336ae) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzdata/tzdata_2018f.bb')
-rw-r--r--meta/recipes-extended/tzdata/tzdata_2018f.bb215
1 files changed, 215 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzdata/tzdata_2018f.bb b/meta/recipes-extended/tzdata/tzdata_2018f.bb
new file mode 100644
index 0000000000..b167540608
--- /dev/null
+++ b/meta/recipes-extended/tzdata/tzdata_2018f.bb
@@ -0,0 +1,215 @@
1SUMMARY = "Timezone data"
2HOMEPAGE = "http://www.iana.org/time-zones"
3SECTION = "base"
4LICENSE = "PD & BSD & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c679c9d6b02bc2757b3eaf8f53c43fba"
6
7DEPENDS = "tzcode-native"
8
9SRC_URI = "http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
11
12SRC_URI[tzdata.md5sum] = "e5e84f00f9d18bd6ebc8b1affec91b15"
13SRC_URI[tzdata.sha256sum] = "0af6a85fc4ea95832f76524f35696a61abb3992fd3f8db33e5a1f95653e043f2"
14
15inherit allarch
16
17RCONFLICTS_${PN} = "timezones timezone-africa timezone-america timezone-antarctica \
18 timezone-arctic timezone-asia timezone-atlantic \
19 timezone-australia timezone-europe timezone-indian \
20 timezone-iso3166.tab timezone-pacific timezone-zone.tab"
21
22S = "${WORKDIR}"
23
24DEFAULT_TIMEZONE ?= "Universal"
25INSTALL_TIMEZONE_FILE ?= "1"
26
27TZONES= "africa antarctica asia australasia europe northamerica southamerica \
28 factory etcetera backward systemv \
29 "
30# pacificnew
31
32do_compile () {
33 for zone in ${TZONES}; do \
34 ${STAGING_BINDIR_NATIVE}/zic -d ${WORKDIR}${datadir}/zoneinfo -L /dev/null \
35 -y ${S}/yearistype.sh ${S}/${zone} ; \
36 ${STAGING_BINDIR_NATIVE}/zic -d ${WORKDIR}${datadir}/zoneinfo/posix -L /dev/null \
37 -y ${S}/yearistype.sh ${S}/${zone} ; \
38 ${STAGING_BINDIR_NATIVE}/zic -d ${WORKDIR}${datadir}/zoneinfo/right -L ${S}/leapseconds \
39 -y ${S}/yearistype.sh ${S}/${zone} ; \
40 done
41}
42
43do_install () {
44 install -d ${D}/$exec_prefix ${D}${datadir}/zoneinfo
45 cp -pPR ${S}/$exec_prefix ${D}/
46 # libc is removing zoneinfo files from package
47 cp -pP "${S}/zone.tab" ${D}${datadir}/zoneinfo
48 cp -pP "${S}/zone1970.tab" ${D}${datadir}/zoneinfo
49 cp -pP "${S}/iso3166.tab" ${D}${datadir}/zoneinfo
50
51 # Install default timezone
52 if [ -e ${D}${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ]; then
53 install -d ${D}${sysconfdir}
54 if [ "${INSTALL_TIMEZONE_FILE}" = "1" ]; then
55 echo ${DEFAULT_TIMEZONE} > ${D}${sysconfdir}/timezone
56 fi
57 ln -s ${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ${D}${sysconfdir}/localtime
58 else
59 bberror "DEFAULT_TIMEZONE is set to an invalid value."
60 exit 1
61 fi
62
63 chown -R root:root ${D}
64}
65
66pkg_postinst_${PN} () {
67 etc_lt="$D${sysconfdir}/localtime"
68 src="$D${sysconfdir}/timezone"
69
70 if [ -e ${src} ] ; then
71 tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
72 fi
73
74 if [ -z "${tz}" ] ; then
75 exit 0
76 fi
77
78 if [ ! -e "$D${datadir}/zoneinfo/${tz}" ] ; then
79 echo "You have an invalid TIMEZONE setting in ${src}"
80 echo "Your ${etc_lt} has been reset to Universal; enjoy!"
81 tz="Universal"
82 echo "Updating ${etc_lt} with $D${datadir}/zoneinfo/${tz}"
83 if [ -L ${etc_lt} ] ; then
84 rm -f "${etc_lt}"
85 fi
86 ln -s "${datadir}/zoneinfo/${tz}" "${etc_lt}"
87 fi
88}
89
90# Packages primarily organized by directory with a major city
91# in most time zones in the base package
92
93PACKAGES = "tzdata tzdata-misc tzdata-posix tzdata-right tzdata-africa \
94 tzdata-americas tzdata-antarctica tzdata-arctic tzdata-asia \
95 tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific"
96
97FILES_tzdata-africa += "${datadir}/zoneinfo/Africa/*"
98RPROVIDES_tzdata-africa = "tzdata-africa"
99
100FILES_tzdata-americas += "${datadir}/zoneinfo/America/* \
101 ${datadir}/zoneinfo/US/* \
102 ${datadir}/zoneinfo/Brazil/* \
103 ${datadir}/zoneinfo/Canada/* \
104 ${datadir}/zoneinfo/Mexico/* \
105 ${datadir}/zoneinfo/Chile/*"
106RPROVIDES_tzdata-americas = "tzdata-americas"
107
108FILES_tzdata-antarctica += "${datadir}/zoneinfo/Antarctica/*"
109RPROVIDES_tzdata-antarctica = "tzdata-antarctica"
110
111FILES_tzdata-arctic += "${datadir}/zoneinfo/Arctic/*"
112RPROVIDES_tzdata-arctic = "tzdata-arctic"
113
114FILES_tzdata-asia += "${datadir}/zoneinfo/Asia/* \
115 ${datadir}/zoneinfo/Indian/* \
116 ${datadir}/zoneinfo/Mideast/*"
117RPROVIDES_tzdata-asia = "tzdata-asia"
118
119FILES_tzdata-atlantic += "${datadir}/zoneinfo/Atlantic/*"
120RPROVIDES_tzdata-atlantic = "tzdata-atlantic"
121
122FILES_tzdata-australia += "${datadir}/zoneinfo/Australia/*"
123RPROVIDES_tzdata-australia = "tzdata-australia"
124
125FILES_tzdata-europe += "${datadir}/zoneinfo/Europe/*"
126RPROVIDES_tzdata-europe = "tzdata-europe"
127
128FILES_tzdata-pacific += "${datadir}/zoneinfo/Pacific/*"
129RPROVIDES_tzdata-pacific = "tzdata-pacific"
130
131FILES_tzdata-posix += "${datadir}/zoneinfo/posix/*"
132RPROVIDES_tzdata-posix = "tzdata-posix"
133
134FILES_tzdata-right += "${datadir}/zoneinfo/right/*"
135RPROVIDES_tzdata-right = "tzdata-right"
136
137
138FILES_tzdata-misc += "${datadir}/zoneinfo/Cuba \
139 ${datadir}/zoneinfo/Egypt \
140 ${datadir}/zoneinfo/Eire \
141 ${datadir}/zoneinfo/Factory \
142 ${datadir}/zoneinfo/GB-Eire \
143 ${datadir}/zoneinfo/Hongkong \
144 ${datadir}/zoneinfo/Iceland \
145 ${datadir}/zoneinfo/Iran \
146 ${datadir}/zoneinfo/Israel \
147 ${datadir}/zoneinfo/Jamaica \
148 ${datadir}/zoneinfo/Japan \
149 ${datadir}/zoneinfo/Kwajalein \
150 ${datadir}/zoneinfo/Libya \
151 ${datadir}/zoneinfo/Navajo \
152 ${datadir}/zoneinfo/Poland \
153 ${datadir}/zoneinfo/Portugal \
154 ${datadir}/zoneinfo/Singapore \
155 ${datadir}/zoneinfo/Turkey"
156RPROVIDES_tzdata-misc = "tzdata-misc"
157
158
159FILES_${PN} += "${datadir}/zoneinfo/Pacific/Honolulu \
160 ${datadir}/zoneinfo/America/Anchorage \
161 ${datadir}/zoneinfo/America/Los_Angeles \
162 ${datadir}/zoneinfo/America/Denver \
163 ${datadir}/zoneinfo/America/Chicago \
164 ${datadir}/zoneinfo/America/New_York \
165 ${datadir}/zoneinfo/America/Caracas \
166 ${datadir}/zoneinfo/America/Sao_Paulo \
167 ${datadir}/zoneinfo/Europe/London \
168 ${datadir}/zoneinfo/Europe/Paris \
169 ${datadir}/zoneinfo/Africa/Cairo \
170 ${datadir}/zoneinfo/Europe/Moscow \
171 ${datadir}/zoneinfo/Asia/Dubai \
172 ${datadir}/zoneinfo/Asia/Karachi \
173 ${datadir}/zoneinfo/Asia/Dhaka \
174 ${datadir}/zoneinfo/Asia/Bangkok \
175 ${datadir}/zoneinfo/Asia/Hong_Kong \
176 ${datadir}/zoneinfo/Asia/Tokyo \
177 ${datadir}/zoneinfo/Australia/Darwin \
178 ${datadir}/zoneinfo/Australia/Adelaide \
179 ${datadir}/zoneinfo/Australia/Brisbane \
180 ${datadir}/zoneinfo/Australia/Sydney \
181 ${datadir}/zoneinfo/Pacific/Noumea \
182 ${datadir}/zoneinfo/CET \
183 ${datadir}/zoneinfo/CST6CDT \
184 ${datadir}/zoneinfo/EET \
185 ${datadir}/zoneinfo/EST \
186 ${datadir}/zoneinfo/EST5EDT \
187 ${datadir}/zoneinfo/GB \
188 ${datadir}/zoneinfo/GMT \
189 ${datadir}/zoneinfo/GMT+0 \
190 ${datadir}/zoneinfo/GMT-0 \
191 ${datadir}/zoneinfo/GMT0 \
192 ${datadir}/zoneinfo/Greenwich \
193 ${datadir}/zoneinfo/HST \
194 ${datadir}/zoneinfo/MET \
195 ${datadir}/zoneinfo/MST \
196 ${datadir}/zoneinfo/MST7MDT \
197 ${datadir}/zoneinfo/NZ \
198 ${datadir}/zoneinfo/NZ-CHAT \
199 ${datadir}/zoneinfo/PRC \
200 ${datadir}/zoneinfo/PST8PDT \
201 ${datadir}/zoneinfo/ROC \
202 ${datadir}/zoneinfo/ROK \
203 ${datadir}/zoneinfo/UCT \
204 ${datadir}/zoneinfo/UTC \
205 ${datadir}/zoneinfo/Universal \
206 ${datadir}/zoneinfo/W-SU \
207 ${datadir}/zoneinfo/WET \
208 ${datadir}/zoneinfo/Zulu \
209 ${datadir}/zoneinfo/zone.tab \
210 ${datadir}/zoneinfo/zone1970.tab \
211 ${datadir}/zoneinfo/iso3166.tab \
212 ${datadir}/zoneinfo/Etc/*"
213
214CONFFILES_${PN} += "${@ "${sysconfdir}/timezone" if bb.utils.to_boolean(d.getVar('INSTALL_TIMEZONE_FILE')) else "" }"
215CONFFILES_${PN} += "${sysconfdir}/localtime"