summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2017b.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2017-03-24 09:01:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-27 08:15:06 +0100
commit33f311b00a8ae90f184812a641dfe8ab5d9f9385 (patch)
tree7ff427d549904e71344bad698d8eec45c5ed74e4 /meta/recipes-extended/tzcode/tzcode-native_2017b.bb
parentc085688a5bd22bd368921a9cc38c0045720c1e78 (diff)
downloadpoky-33f311b00a8ae90f184812a641dfe8ab5d9f9385.tar.gz
tzcode: update to 2017b
Briefly: Haiti has resumed DST. Changes to past and future time stamps Haiti resumed observance of DST in 2017. (Thanks to Steffen Thorsen.) Changes to past time stamps Liberia changed from -004430 to +00 on 1972-01-07, not 1972-05-01. Use "MMT" to abbreviate Liberia's time zone before 1972, as "-004430" is one byte over the POSIX limit. (Problem reported by Derick Rethans.) (From OE-Core rev: 70ff7cfa8a7ffb537da19aeca026032bab55a00d) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2017b.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2017b.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2017b.bb b/meta/recipes-extended/tzcode/tzcode-native_2017b.bb
new file mode 100644
index 0000000000..2084f79d52
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2017b.bb
@@ -0,0 +1,28 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ef1a352b901ee7b75a75df8171d6aca7"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
11
12SRC_URI[tzcode.md5sum] = "afaf15deb13759e8b543d86350385b16"
13SRC_URI[tzcode.sha256sum] = "4d1735bb54e22b8d7443d4d1f1a13d007ae11be79a35e51f8e8322fb8e292d40"
14SRC_URI[tzdata.md5sum] = "50dc0dc50c68644c1f70804f2e7a1625"
15SRC_URI[tzdata.sha256sum] = "f8242a522ea3496b0ce4ff4f2e75a049178da21001a08b8e666d8cbe07d18086"
16
17S = "${WORKDIR}"
18
19inherit native
20
21EXTRA_OEMAKE += "cc=${CC}"
22
23do_install () {
24 install -d ${D}${bindir}/
25 install -m 755 zic ${D}${bindir}/
26 install -m 755 zdump ${D}${bindir}/
27 install -m 755 tzselect ${D}${bindir}/
28}