summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016i.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-11-03 22:53:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-11 17:21:41 +0000
commitafaef2018fb0c2d7b7f30d2eb396b0599dbbd7a5 (patch)
tree0430bda6f30ac431b98b5b802f18fab3c7caf6ed /meta/recipes-extended/tzcode/tzcode-native_2016i.bb
parent724fa5a48967d1d131b425f87fdd8d0b3b87c286 (diff)
downloadpoky-afaef2018fb0c2d7b7f30d2eb396b0599dbbd7a5.tar.gz
tzcode: update to 2016i
Changes to code The code should now be buildable on AmigaOS merely by setting the appropriate Makefile variables. (From a patch by Carsten Larsen.) (From OE-Core rev: d2b8c4ee535684f5d874082a7f76efbda1907ea5) (From OE-Core rev: 757f2cb2f2acaf41d3f81c5b9bb0afd8e05001db) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016i.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016i.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016i.bb b/meta/recipes-extended/tzcode/tzcode-native_2016i.bb
new file mode 100644
index 0000000000..9d3d5a1334
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016i.bb
@@ -0,0 +1,26 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ef1a352b901ee7b75a75df8171d6aca7"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
11
12SRC_URI[tzcode.md5sum] = "8fae14cba9396462955b7859cf04ba48"
13SRC_URI[tzcode.sha256sum] = "411e8adcb6288b17d6c2624fde65e7d82654ca69b813ae121504ff66f0cfba7b"
14SRC_URI[tzdata.md5sum] = "73912ecfa6a9a8048ddf2e719d9bc39d"
15SRC_URI[tzdata.sha256sum] = "b6966ec982ef64fe48cebec437096b4f57f4287519ed32dde59c86d3a1853845"
16
17S = "${WORKDIR}"
18
19inherit native
20
21do_install () {
22 install -d ${D}${bindir}/
23 install -m 755 zic ${D}${bindir}/
24 install -m 755 zdump ${D}${bindir}/
25 install -m 755 tzselect ${D}${bindir}/
26}