summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2015g.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-10-02 07:24:52 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-07 00:09:11 +0100
commit931dda4d9adbefa68b8e6e9796d55a9e3d2bfcee (patch)
tree25165feb07b7d4dd05480c097ad71a2ab6ea8987 /meta/recipes-extended/tzcode/tzcode-native_2015g.bb
parent8cacd228e674f16804f3a09c776068073b31791a (diff)
downloadpoky-931dda4d9adbefa68b8e6e9796d55a9e3d2bfcee.tar.gz
tzcode: update to 2015g
Changes affecting code localtime no longer mishandles America/Anchorage after 2037. (Thanks to Bradley White for reporting the bug.) On hosts with signed 32-bit time_t, localtime no longer mishandles Pacific/Fiji after 2038-01-16 14:00 UTC. The localtime module allows the variables 'timezone', 'daylight', and 'altzone' to be in common storage shared with other modules, and declares them in case the system <time.h> does not. (Problems reported by Kees Dekker.) On platforms with tm_zone, strftime.c now assumes it is not NULL. This simplifies the code and is consistent with zdump.c. (Problem reported by Christos Zoulas.) Changes affecting documentation The tzfile man page now documents that transition times denote the starts (not the ends) of the corresponding time periods. (Ambiguity reported by Bill Seymour.) (From OE-Core rev: 7c9082ab1ae6f7810c7cffe137d7d232b03852f8) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2015g.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2015g.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2015g.bb b/meta/recipes-extended/tzcode/tzcode-native_2015g.bb
new file mode 100644
index 0000000000..989e24b311
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2015g.bb
@@ -0,0 +1,25 @@
1# note that we allow for us to use data later than our code version
2#
3DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD"
5
6LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=d0ff93a73dd5bc3c6e724bb4343760f6"
7
8SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
9 ftp://ftp.iana.org/tz/releases/tzdata2015g.tar.gz;name=tzdata"
10
11SRC_URI[tzcode.md5sum] = "a2c47d908a6426f530efb1393cf1cd06"
12SRC_URI[tzcode.sha256sum] = "18e402ef24bfad2ded38643c9a7a9a580f940a729cb47d983052fc28ff0c7ec4"
13SRC_URI[tzdata.md5sum] = "8d46e8b225b9a04c75f5c39636435ad6"
14SRC_URI[tzdata.sha256sum] = "b923cdbf078491696b17bc8d069c74bce73fabc5774629da2f410c9b31576161"
15
16S = "${WORKDIR}"
17
18inherit native
19
20do_install () {
21 install -d ${D}${bindir}/
22 install -m 755 zic ${D}${bindir}/
23 install -m 755 zdump ${D}${bindir}/
24 install -m 755 tzselect ${D}${bindir}/
25}