diff options
author | Edwin Plauchu <edwin.plauchu.camacho@intel.com> | 2016-12-02 15:36:19 -0600 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-12-08 10:31:29 +0000 |
commit | 674c216c69cc2cbfcd45ce001afe5a7f262179a4 (patch) | |
tree | fb14a04c2506a2b8ec639bb642b42f14d9ae7337 /meta/recipes-extended/texinfo/texinfo_6.3.bb | |
parent | bc209d9b8dbfb842eb00f0a09e52025f1ca403ae (diff) | |
download | poky-674c216c69cc2cbfcd45ce001afe5a7f262179a4.tar.gz |
texinfo: upgrade from 6.0 to 6.3
(From OE-Core rev: 8c85ffa135d96df6e3ed0b318e4e7db570e53da5)
Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/texinfo/texinfo_6.3.bb')
-rw-r--r-- | meta/recipes-extended/texinfo/texinfo_6.3.bb | 82 |
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo_6.3.bb b/meta/recipes-extended/texinfo/texinfo_6.3.bb new file mode 100644 index 0000000000..51199be758 --- /dev/null +++ b/meta/recipes-extended/texinfo/texinfo_6.3.bb | |||
@@ -0,0 +1,82 @@ | |||
1 | SUMMARY = "Documentation system for on-line information and printed output" | ||
2 | DESCRIPTION = "Texinfo is a documentation system that can produce both \ | ||
3 | online information and printed output from a single source file. The \ | ||
4 | GNU Project uses the Texinfo file format for most of its documentation." | ||
5 | HOMEPAGE = "http://www.gnu.org/software/texinfo/" | ||
6 | SECTION = "console/utils" | ||
7 | LICENSE = "GPLv3+" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
9 | |||
10 | PROVIDES_append_class-native = " texinfo-replacement-native" | ||
11 | |||
12 | def compress_pkg(d): | ||
13 | if bb.data.inherits_class('compress_doc', d): | ||
14 | compress = d.getVar("DOC_COMPRESS", True) | ||
15 | if compress == "gz": | ||
16 | return "gzip" | ||
17 | elif compress == "bz2": | ||
18 | return "bzip2" | ||
19 | elif compress == "xz": | ||
20 | return "xz" | ||
21 | return "" | ||
22 | |||
23 | RDEPENDS_info += "${@compress_pkg(d)}" | ||
24 | |||
25 | DEPENDS = "zlib ncurses texinfo-replacement-native" | ||
26 | DEPENDS_class-native = "zlib-native ncurses-native" | ||
27 | |||
28 | TARGET_PATCH = "file://use_host_makedoc.patch" | ||
29 | TARGET_PATCH_class-native = "" | ||
30 | |||
31 | SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \ | ||
32 | file://texinfo-4.12-zlib.patch \ | ||
33 | file://disable-native-tools.patch \ | ||
34 | file://link-zip.patch \ | ||
35 | file://dont-depend-on-help2man.patch \ | ||
36 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ | ||
37 | ${TARGET_PATCH} \ | ||
38 | " | ||
39 | |||
40 | SRC_URI[md5sum] = "9b08daca9bf8eccae9b0f884aba41f9e" | ||
41 | SRC_URI[sha256sum] = "300a6ba4958c2dd4a6d5ce60f0a335daf7e379f5374f276f6ba31a221f02f606" | ||
42 | |||
43 | tex_texinfo = "texmf/tex/texinfo" | ||
44 | |||
45 | inherit gettext autotools | ||
46 | |||
47 | do_configure_prepend () { | ||
48 | # autotools_do_configure updates po/Makefile.in.in, we also need | ||
49 | # update po_document. | ||
50 | cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/ | ||
51 | } | ||
52 | |||
53 | do_compile_prepend() { | ||
54 | if [ -d tools ];then | ||
55 | oe_runmake -C tools/gnulib/lib | ||
56 | fi | ||
57 | } | ||
58 | |||
59 | do_install_append() { | ||
60 | mkdir -p ${D}${datadir}/${tex_texinfo} | ||
61 | install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo} | ||
62 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2any ${D}${bindir}/pod2texi | ||
63 | } | ||
64 | |||
65 | do_install_append_class-native() { | ||
66 | install -m 755 info/makedoc ${D}${bindir} | ||
67 | } | ||
68 | |||
69 | PACKAGES += "info info-doc" | ||
70 | |||
71 | FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info" | ||
72 | FILES_info-doc = "${infodir}/info.info* ${infodir}/dir ${infodir}/info-*.info* \ | ||
73 | ${mandir}/man1/info.1* ${mandir}/man5/info.5* \ | ||
74 | ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*" | ||
75 | |||
76 | FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo" | ||
77 | RDEPENDS_${PN} = "perl" | ||
78 | FILES_${PN}-doc = "${infodir}/texinfo* \ | ||
79 | ${datadir}/${tex_texinfo} \ | ||
80 | ${mandir}/man1 ${mandir}/man5" | ||
81 | |||
82 | BBCLASSEXTEND = "native nativesdk" | ||