summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texi2html/texi2html_5.0.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/texi2html/texi2html_5.0.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/texi2html/texi2html_5.0.bb')
-rw-r--r--meta/recipes-extended/texi2html/texi2html_5.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/texi2html/texi2html_5.0.bb b/meta/recipes-extended/texi2html/texi2html_5.0.bb
new file mode 100644
index 0000000000..a22b981a5d
--- /dev/null
+++ b/meta/recipes-extended/texi2html/texi2html_5.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Perl script that converts Texinfo to HTML"
2HOMEPAGE = "http://www.nongnu.org/texi2html/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6
7PR = "r2"
8
9SRC_URI = "http://download.savannah.gnu.org/releases/texi2html/${BPN}-${PV}.tar.bz2 \
10 file://fix_gettext_version.patch"
11
12SRC_URI[md5sum] = "f15ac876fcdc8be865b16535f480aa54"
13SRC_URI[sha256sum] = "e8a98b0ee20c495a6ab894398a065ef580272dbd5a15b1b19e8bd1bc89d9f9fa"
14
15inherit autotools gettext
16
17do_configure_prepend() {
18 # Make a directory for the old gettext setup
19 if [ ! -d ${S}/po ]; then
20 mkdir ${S}/po
21 fi
22}
23
24do_configure_append() {
25 # Clean up the phony po directory
26 rm -rf ${S}/po
27}
28
29do_install_append () {
30 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2html
31}
32
33FILES_${PN}-doc += "${datadir}/texinfo"