summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sudo/sudo_1.8.4.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-02-28 13:45:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-02 15:22:53 +0000
commit60eed3195cadf001ef683e96a5e65be5c1a2dde5 (patch)
tree9f80a9a81d1b31313b318adb913fe10bd30e84c9 /meta/recipes-extended/sudo/sudo_1.8.4.bb
parent78ae63423f123f89a5c72c85539e6ed71bd2653d (diff)
downloadpoky-60eed3195cadf001ef683e96a5e65be5c1a2dde5.tar.gz
sudo: upgrade to 1.8.4
During the upgrade to 1.8.4, the UCB-licensed fnmatch.c was replaced with a non-recursive BSD-licensed version, hence the removal of UCB and addition of BSD in the LICENSE field. This led to checksum changes in the doc/LICENSE file, and we now additionally track the comment headers in redblack.c. These changes were confirmed on the sudo mailing list: http://www.sudo.ws/pipermail/sudo-workers/2012-February/000736.html This upgrade also fixes CVE-2012-0809. (From OE-Core rev: 7147a569758414467c9d022e4c11fbc303e050aa) Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/sudo/sudo_1.8.4.bb')
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/sudo/sudo_1.8.4.bb b/meta/recipes-extended/sudo/sudo_1.8.4.bb
new file mode 100644
index 0000000000..dfa7291c55
--- /dev/null
+++ b/meta/recipes-extended/sudo/sudo_1.8.4.bb
@@ -0,0 +1,29 @@
1require sudo.inc
2
3PR = "r1"
4
5SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-${PV}.tar.gz \
6 file://libtool.patch \
7 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
8
9PAM_SRC_URI = "file://sudo.pam"
10
11SRC_URI[md5sum] = "5a54dde137618bbc1dd46bb0ef725d7d"
12SRC_URI[sha256sum] = "17a91da1857954aa73445197e6f73d5d50cc8c48719f6db457723bb8badc32a5"
13
14DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
15RDEPENDS_${PN} += " ${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-limits pam-plugin-keyinit', '', d)}"
16
17EXTRA_OECONF += " ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)}"
18
19do_install_append () {
20 for feature in ${DISTRO_FEATURES}; do
21 if [ "$feature" = "pam" ]; then
22 install -D -m 664 ${WORKDIR}/sudo.pam ${D}/${sysconfdir}/pam.d/sudo
23 break
24 fi
25 done
26
27 chmod 4111 $D/usr/bin/sudo
28 chmod 0440 $D/etc/sudoers
29}