diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2016-07-25 01:16:28 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-07-26 08:56:26 +0100 |
commit | 91a6f3a3756219ae91435d60a0ceb8fd36fd056f (patch) | |
tree | 21bdd5c6f6e46fbbbbbcca4e26fe1e01e0e7c037 /meta/recipes-extended/slang/slang_2.3.0.bb | |
parent | 2186bbca70cfcec42b01484126d654bfec987ae0 (diff) | |
download | poky-91a6f3a3756219ae91435d60a0ceb8fd36fd056f.tar.gz |
slang: 2.2.4 -> 2.3.0
* Removed:
change-char-type-to-signed-char-in-macros.patch
sprintf-bug-concerning-8-bit-characters.patch
They are already in the source.
* Updated:
fix-check-pcre.patch
fix-check-pcre.patch
slang-fix-the-iconv-existence-checking.patch
* Use SECURITY_NO_PIE_CFLAGS for SECURITY_CFLAGS, it can't be built with
"-pie -fpie":
tmp/sysroots/qemux86-64/usr/lib64/../lib64/Scrt1.o: In function `_start':
/usr/src/debug/glibc/2.24-r0/git/csu/../sysdeps/x86_64/start.S:104: undefined reference to `main'
/tmp/ccMFTA8A.o: In function `smg_char_at':
/usr/src/debug/slang/2.3.0-r0/slang-2.3.0/modules/slsmg-module.c:134: undefined reference to `SLsmg_char_at'
/tmp/ccMFTA8A.o: In function `smg_resume_smg':
(From OE-Core rev: b2d6e069b9ecc5a13754393200a6fa48cdaaf4c6)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.3.0.bb')
-rw-r--r-- | meta/recipes-extended/slang/slang_2.3.0.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.3.0.bb b/meta/recipes-extended/slang/slang_2.3.0.bb new file mode 100644 index 0000000000..17efbbe223 --- /dev/null +++ b/meta/recipes-extended/slang/slang_2.3.0.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SUMMARY = "The shared library for the S-Lang extension language" | ||
2 | |||
3 | DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \ | ||
4 | S-Lang language was designed so that it can be easily embedded into \ | ||
5 | a program to provide the program with a powerful extension language. \ | ||
6 | The S-Lang library, provided in this package, provides the S-Lang \ | ||
7 | extension language. S-Lang's syntax resembles C, which makes it easy \ | ||
8 | to recode S-Lang procedures in C if you need to." | ||
9 | |||
10 | HOMEPAGE = "http://www.jedsoft.org/slang/" | ||
11 | SECTION = "libs" | ||
12 | DEPENDS = "pcre ncurses" | ||
13 | |||
14 | LICENSE = "GPLv2" | ||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02" | ||
16 | |||
17 | |||
18 | SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \ | ||
19 | file://rpathfix.patch \ | ||
20 | file://fix-check-pcre.patch \ | ||
21 | file://slang-fix-the-iconv-existence-checking.patch \ | ||
22 | file://0001-Fix-error-conflicting-types-for-posix_close.patch \ | ||
23 | " | ||
24 | UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/" | ||
25 | |||
26 | inherit autotools-brokensep | ||
27 | |||
28 | CLEANBROKEN = "1" | ||
29 | |||
30 | SRC_URI[md5sum] = "3bcc790460d52db1316c20395b7ac2f1" | ||
31 | SRC_URI[sha256sum] = "f95224060f45e0d8212a5039b339afa5f1a94a1bb0298e796104e5b12e926129" | ||
32 | |||
33 | EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib" | ||
34 | |||
35 | do_configure_prepend() { | ||
36 | # slang keeps configure.ac and rest of autoconf files in autoconf/ directory | ||
37 | # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac} | ||
38 | # to be present. Resulting files land in autoconf/autoconf/ so we need to move them. | ||
39 | cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* . | ||
40 | cd ${B} | ||
41 | } | ||
42 | |||
43 | do_install() { | ||
44 | oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib' | ||
45 | } | ||
46 | |||
47 | FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/" | ||
48 | |||
49 | PARALLEL_MAKE = "" | ||
50 | |||
51 | BBCLASSEXTEND = "native" | ||