summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-07-27 16:04:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:35 +0100
commitffb63803eac6ba97d1b9e1f3d648bc4d81bf0276 (patch)
treed29c106cf81ae93e47b30aaaf87e10bbcdfc10eb /meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
parent96f011e628fe360644bfdd7650145b996d61740c (diff)
downloadpoky-ffb63803eac6ba97d1b9e1f3d648bc4d81bf0276.tar.gz
shadow: upgrade 4.2.1 -> 4.6
The following patches are removed because problems have been fixed in this version. 0001-shadow-CVE-2017-12424 fix-installation-failure-with-subids-disabled.patch usermod-fix-compilation-failure-with-subids-disabled.patch CVE-2017-2616.patch check_size_of_uid_t_and_gid_t_using_AC_CHECK_SIZEOF.patch 0001-Do-not-read-login.defs-before-doing-chroot.patch The following patches are rebased. 0001-Disable-use-of-syslog-for-sysroot.patch 0001-useradd-copy-extended-attributes-of-home.patch 0001-useradd.c-create-parent-directories-when-necessary.patch allow-for-setting-password-in-clear-text.patch (From OE-Core rev: 79dd22729d5b8a2f2cf4294ff6b261c9d6ecd977) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/shadow/shadow-sysroot_4.6.bb')
-rw-r--r--meta/recipes-extended/shadow/shadow-sysroot_4.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb b/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
new file mode 100644
index 0000000000..ef014628f6
--- /dev/null
+++ b/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Shadow utils requirements for useradd.bbclass"
2HOMEPAGE = "http://pkg-shadow.alioth.debian.org"
3BUGTRACKER = "https://alioth.debian.org/tracker/?group_id=30580"
4SECTION = "base utils"
5LICENSE = "BSD | Artistic-1.0"
6LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;md5=25e2f2de4dfc8f966ac5cdfce45cd7d5"
7
8DEPENDS = "base-passwd"
9
10PR = "r3"
11
12# The sole purpose of this recipe is to provide the /etc/login.defs
13# file for the target sysroot - needed so the shadow-native utilities
14# can add custom users/groups for recipes that use inherit useradd.
15SRC_URI = "file://login.defs_shadow-sysroot"
16
17SRC_URI[md5sum] = "b8608d8294ac88974f27b20f991c0e79"
18SRC_URI[sha256sum] = "633f5bb4ea0c88c55f3642c97f9d25cbef74f82e0b4cf8d54e7ad6f9f9caa778"
19
20S = "${WORKDIR}"
21
22do_install() {
23 install -d ${D}${sysconfdir}
24 install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
25}
26
27SYSROOT_DIRS += "${sysconfdir}"
28
29# don't create any packages
30# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
31# and this has another copy of /etc/login.defs already provided by shadow
32PACKAGES = ""