diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2014-07-17 15:53:34 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-07-17 12:36:18 +0100 |
commit | 012a572e861d95d35c97a4da34dbad6d93cc9962 (patch) | |
tree | bb885411bed3c3990523650ccf1d10cd004d7328 /meta/recipes-extended/shadow/shadow-securetty_4.2.1.bb | |
parent | 3ab35e4a47fdf76f86b7b84fbb61e79a25b230fa (diff) | |
download | poky-012a572e861d95d35c97a4da34dbad6d93cc9962.tar.gz |
shadow: upgrade from 4.1.4.3 to 4.2.1
Upgrade shadow from 4.1.4.3 to 4.2.1.
Changes during this upgrade are as following.
1. Remove the "merged" patches. These patches are either merged or
the same functionality has been implemented upstream.
add_root_cmd_groupmems.patch
add_root_cmd_options.patch
fix-etc-gshadow-reading.patch
shadow-4.1.4.2-env-reset-keep-locale.patch
shadow-4.1.4.2-groupmod-pam-check.patch
shadow-4.1.4.2-su_no_sanitize_env.patch
shadow.automake-1.11.patch
shadow_fix_for_automake-1.12.patch
useradd.patch
2. Remove the unneeded patch.
The following patch has been removed because the logic in the related
codes of the new version has been changed. In specific, the codes now
can handle the 'NULL' return value. So there's no need for the following
patch.
slackware_fix_for_glib-2.17_crypt.patch
3. Teak the current patch to match the new version.
allow-for-setting-password-in-clear-text.patch
4. Add a patch to fix compilation failure.
usermod-fix-compilation-failure-with-subids-disabled.patch
5. Add a patch to fix the installation failure.
fix-installation-failure-with-subids-disabled.patch
5. Add a patch to fix the failure at rootfs time if extrausers is inherited.
commonio.c-fix-unexpected-open-failure-in-chroot-env.patch
6. Fix the bad section in the recipe.
7. Disable the new subids feature in the new version as it doesn't support
cross compilation for now.
8. Modify the pkg_postinst to `exit 1' if the `pwconv' or `grpconv' fails.
Also, fix the arguments to use '--root $D' instead of '--root=$D'.
9. Add a patch for shadow-native to create parent directories when necessary.
0001-useradd.c-create-parent-directories-when-necessary.patch
(From OE-Core rev: b73e5cd51551556f9e6a4f7d9e7deec4d9d661bd)
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/shadow/shadow-securetty_4.2.1.bb')
-rw-r--r-- | meta/recipes-extended/shadow/shadow-securetty_4.2.1.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/shadow/shadow-securetty_4.2.1.bb b/meta/recipes-extended/shadow/shadow-securetty_4.2.1.bb new file mode 100644 index 0000000000..0e0410043b --- /dev/null +++ b/meta/recipes-extended/shadow/shadow-securetty_4.2.1.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Provider of the machine specific securetty file" | ||
2 | SECTION = "base utils" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
5 | |||
6 | INHIBIT_DEFAULT_DEPS = "1" | ||
7 | |||
8 | PR = "r3" | ||
9 | |||
10 | SRC_URI = "file://securetty" | ||
11 | |||
12 | # Since SERIAL_CONSOLES is likely to be set from the machine configuration | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | |||
15 | do_install () { | ||
16 | # Ensure we add a suitable securetty file to the package that has | ||
17 | # most common embedded TTYs defined. | ||
18 | install -d ${D}${sysconfdir} | ||
19 | install -m 0400 ${WORKDIR}/securetty ${D}${sysconfdir}/securetty | ||
20 | if [ ! -z "${SERIAL_CONSOLES}" ]; then | ||
21 | # Our SERIAL_CONSOLES contains a baud rate and sometimes extra | ||
22 | # options as well. The following pearl :) takes that and converts | ||
23 | # it into newline-separated tty's and appends them into | ||
24 | # securetty. So if a machine has a weird looking console device | ||
25 | # node (e.g. ttyAMA0) that securetty does not know, it will get | ||
26 | # appended to securetty and root logins will be allowed on that | ||
27 | # console. | ||
28 | tmp="${SERIAL_CONSOLES}" | ||
29 | for entry in $tmp ; do | ||
30 | ttydev=`echo "$entry" | sed -e 's/^[0-9]*\;//' -e 's/\;.*//'` | ||
31 | if ! grep -q $ttydev ${D}${sysconfdir}/securetty; then | ||
32 | echo $ttydev >> ${D}${sysconfdir}/securetty | ||
33 | fi | ||
34 | done | ||
35 | fi | ||
36 | } | ||