summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed/sed_4.2.2.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2013-01-07 11:21:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-07 12:06:26 +0000
commit09fe48b47ac6e73df7ab9a6ee909a3e2f575ad12 (patch)
tree2a25e7c7f249d397d799f4a9f559ebc112a31c1a /meta/recipes-extended/sed/sed_4.2.2.bb
parent3547f3e191e6779ae8446ee129459626314e39d5 (diff)
downloadpoky-09fe48b47ac6e73df7ab9a6ee909a3e2f575ad12.tar.gz
sed: upgrade to 4.2.2
(From OE-Core rev: 16500f9d5fe3446511212cff14d44bce969cdea0) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/sed/sed_4.2.2.bb')
-rw-r--r--meta/recipes-extended/sed/sed_4.2.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/sed/sed_4.2.2.bb b/meta/recipes-extended/sed/sed_4.2.2.bb
new file mode 100644
index 0000000000..8f4e0419e5
--- /dev/null
+++ b/meta/recipes-extended/sed/sed_4.2.2.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "sed is a Stream EDitor."
2HOMEPAGE = "http://www.gnu.org/software/sed/"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
5 file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f"
6SECTION = "console/utils"
7PR = "r0"
8
9SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "4111de4faa3b9848a0686b2f260c5056"
12SRC_URI[sha256sum] = "fea0a94d4b605894f3e2d5572e3f96e4413bcad3a085aae7367c2cf07908b2ff"
13
14inherit autotools update-alternatives gettext
15
16EXTRA_OECONF = "--disable-acl"
17
18do_install () {
19 autotools_do_install
20 install -d ${D}${base_bindir}
21 mv ${D}${bindir}/sed ${D}${base_bindir}/sed
22 rmdir ${D}${bindir}/
23}
24
25ALTERNATIVE_${PN} = "sed"
26ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
27ALTERNATIVE_PRIORITY = "100"
28
29BBCLASSEXTEND = "native"