summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sat-solver/sat-solver_git.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-04-13 16:59:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 10:44:19 +0100
commit181d5f550d06aaf76ba20666664895355ba6ccea (patch)
tree589621778221ef12ab240d157a3a7a155c6ec3d0 /meta/recipes-extended/sat-solver/sat-solver_git.bb
parent927d33c170f062c0a59d2a321679d5fe22e80a97 (diff)
downloadpoky-181d5f550d06aaf76ba20666664895355ba6ccea.tar.gz
sat-solver: fix arch=all packages
add a new options to set noarch archs as all so platform independent packages can be recognized and installed. fixes [YOCTO #993] (From OE-Core rev: bd0798120559a8aca726db8e962bbbafb80c2a54) Signed-off-by: Qing He <qing.he@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/sat-solver/sat-solver_git.bb')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
index a6937763cb..2d4d29932a 100644
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ b/meta/recipes-extended/sat-solver/sat-solver_git.bb
@@ -7,19 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
7DEPENDS = "libcheck rpm zlib expat db" 7DEPENDS = "libcheck rpm zlib expat db"
8 8
9PV = "0.0-git${SRCPV}" 9PV = "0.0-git${SRCPV}"
10PR = "r8" 10PR = "r9"
11 11
12SRC_URI = "git://gitorious.org/opensuse/sat-solver.git;protocol=git \ 12SRC_URI = "git://gitorious.org/opensuse/sat-solver.git;protocol=git \
13 file://sat-solver_rpm5.patch \ 13 file://sat-solver_rpm5.patch \
14 file://sat-solver_obsolete.patch \ 14 file://sat-solver_obsolete.patch \
15 file://cmake.patch \ 15 file://cmake.patch \
16 file://db5.patch \ 16 file://db5.patch \
17 file://sat-solver_poky.patch \ 17 file://sat-solver_core.patch \
18 " 18 "
19 19
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21 21
22EXTRA_OECMAKE += "-DLIB=lib -DRPM5=RPM5" 22EXTRA_OECMAKE += "-DLIB=lib -DRPM5=RPM5 -DOE_CORE=OE_CORE"
23 23
24inherit cmake pkgconfig 24inherit cmake pkgconfig
25 25
@@ -38,18 +38,18 @@ do_archgen () {
38 INSTALL_PLATFORM_ARCHS="$each_arch $INSTALL_PLATFORM_ARCHS" 38 INSTALL_PLATFORM_ARCHS="$each_arch $INSTALL_PLATFORM_ARCHS"
39 done 39 done
40 40
41 echo "/* Automatically generated by the sat-solver recipe */" > src/poky-arch.h 41 echo "/* Automatically generated by the sat-solver recipe */" > src/core-arch.h
42 echo "const char *archpolicies[] = {" >> src/poky-arch.h 42 echo "const char *archpolicies[] = {" >> src/core-arch.h
43 43
44 set -- $INSTALL_PLATFORM_ARCHS 44 set -- $INSTALL_PLATFORM_ARCHS
45 45
46 save_IFS=$IFS 46 save_IFS=$IFS
47 IFS=: 47 IFS=:
48 while [ $# -gt 0 ]; do echo " \"$1\", "\""$*"\", >> src/poky-arch.h ; shift; done 48 while [ $# -gt 0 ]; do echo " \"$1\", "\""$*"\", >> src/core-arch.h ; shift; done
49 IFS=$save_IFS 49 IFS=$save_IFS
50 50
51 echo " 0" >> src/poky-arch.h 51 echo " 0" >> src/core-arch.h
52 echo "};" >> src/poky-arch.h 52 echo "};" >> src/core-arch.h
53} 53}
54 54
55addtask archgen before do_configure after do_patch 55addtask archgen before do_configure after do_patch