summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-11-13 11:14:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-14 11:14:40 +0000
commita5de19553e401f49d63626be102cc99d7d2539d9 (patch)
treed74602053c32786691a457a371091d6d1bb8739c /meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
parenta97bfad798d8318dbe93b21bb025f280105cb879 (diff)
downloadpoky-a5de19553e401f49d63626be102cc99d7d2539d9.tar.gz
rpcbind: 0.2.4 -> 1.2.5
- Drop backport fixes 0001-rpcbind-pair-all-svc_getargs-calls-with-svc_freeargs.patch pmapproc_dump-Fixed-typo-in-memory-leak-patch.patch rpcbproc_callit_com-Stop-freeing-a-static-pointer.patch - Do not manually move binaries from bindir to sbindir, the upstream already moved rpcbind from bin_PROGRAMS to sbin_PROGRAMS in Makefile.am https://git.linux-nfs.org/?p=steved/rpcbind.git;a=commitdiff;h=9afccfcd5ab350d6bc72622f3d1ccfb9e54652b0 (From OE-Core rev: 3df591cd914a4f060f0a178a59c93b464192d80d) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb')
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb b/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
new file mode 100644
index 0000000000..7c96aca36b
--- /dev/null
+++ b/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Universal Addresses to RPC Program Number Mapper"
2DESCRIPTION = "The rpcbind utility is a server that converts RPC \
3 program numbers into universal addresses."
4SECTION = "console/network"
5HOMEPAGE = "http://sourceforge.net/projects/rpcbind/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751"
7DEPENDS = "libtirpc quota"
8
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
11 file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
14 file://init.d \
15 file://rpcbind.conf \
16 file://rpcbind.socket \
17 file://rpcbind.service \
18 file://rpcbind_add_option_to_fix_port_number.patch \
19 "
20SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b"
21SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a"
22
23inherit autotools update-rc.d systemd pkgconfig
24
25PACKAGECONFIG ??= "tcp-wrappers"
26PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
27
28INITSCRIPT_NAME = "rpcbind"
29INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
30
31SYSTEMD_SERVICE_${PN} = "rpcbind.service"
32
33inherit useradd
34
35USERADD_PACKAGES = "${PN}"
36USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \
37 --shell /bin/false --user-group rpc"
38
39PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
40PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \
41 --without-systemdsystemunitdir, \
42 systemd \
43"
44
45EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc"
46
47do_install_append () {
48 install -d ${D}${sysconfdir}/init.d
49 sed -e 's,/etc/,${sysconfdir}/,g' \
50 -e 's,/sbin/,${sbindir}/,g' \
51 ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
52 chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
53
54 install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}
55 install -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@SBINDIR@,${sbindir},g' \
59 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
60 ${D}${systemd_unitdir}/system/rpcbind.service
61}