summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-11-22 16:24:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-27 13:25:18 +0000
commit63dd6190cbd5c64780522576e8df0aef66b711d8 (patch)
treecbb09594327eec1be08cd999db870a61fa99e690 /meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
parente6254f385e3b4f63a3e59957f6511cf9ed209842 (diff)
downloadpoky-63dd6190cbd5c64780522576e8df0aef66b711d8.tar.gz
rpcbind: use upstream systemd service
Use upstream systemd service files instead of our own service files. This also makes sure that /run/rpcbind.sock is used which fixes the following systemd warning: /usr/lib/systemd/system/rpcbind.socket:5: ListenStream= references a path below legacy directory /var/run/, updating /var/run/rpcbind.sock \xe2\x86\x92 /run/rpcbind.sock; please update the unit file accordingly. (From OE-Core rev: ad08385393bb0d072f2f27f5a189041037e06195) Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb')
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb13
1 files changed, 2 insertions, 11 deletions
diff --git a/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb b/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
index 19d778b6d1..aff00e56e6 100644
--- a/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
+++ b/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
@@ -13,9 +13,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \ 13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
14 file://init.d \ 14 file://init.d \
15 file://rpcbind.conf \ 15 file://rpcbind.conf \
16 file://rpcbind.socket \
17 file://rpcbind.service \
18 file://rpcbind_add_option_to_fix_port_number.patch \ 16 file://rpcbind_add_option_to_fix_port_number.patch \
17 file://0001-systemd-use-EnvironmentFile.patch \
19 " 18 "
20SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b" 19SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b"
21SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a" 20SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a"
@@ -28,7 +27,7 @@ PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
28INITSCRIPT_NAME = "rpcbind" 27INITSCRIPT_NAME = "rpcbind"
29INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ." 28INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
30 29
31SYSTEMD_SERVICE_${PN} = "rpcbind.service" 30SYSTEMD_SERVICE_${PN} = "rpcbind.service rpcbind.socket"
32 31
33inherit useradd 32inherit useradd
34 33
@@ -50,12 +49,4 @@ do_install_append () {
50 -e 's,/sbin/,${sbindir}/,g' \ 49 -e 's,/sbin/,${sbindir}/,g' \
51 ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind 50 ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
52 chmod 0755 ${D}${sysconfdir}/init.d/rpcbind 51 chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
53
54 install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}
55 install -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@SBINDIR@,${sbindir},g' \
59 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
60 ${D}${systemd_unitdir}/system/rpcbind.service
61} 52}