summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-02-07 00:37:22 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 20:06:42 -0800
commit3026b4cdd98daf667ca5996ed43c1fcf98cb1cfe (patch)
tree107357bf984bed234bbfac16bf137a9820c3ebb8 /meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb
parent1831b720c2b939bd2b3c0841c797b39ff8f5493c (diff)
downloadpoky-3026b4cdd98daf667ca5996ed43c1fcf98cb1cfe.tar.gz
rpcbind: 0.2.3 -> 0.2.4
Drop obsolete patch - 0001-Avoid-use-of-glibc-sys-cdefs.h-header.patch Drop backport patches: - 0001-handle_reply-Don-t-use-the-xp_auth-pointer-directly.patch - cve-2015-7236.patch (From OE-Core rev: 6d65a58f5c062b503ab41b38fb2e74df71a9a8c6) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb')
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb b/meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb
new file mode 100644
index 0000000000..53cd59d833
--- /dev/null
+++ b/meta/recipes-extended/rpcbind/rpcbind_0.2.4.bb
@@ -0,0 +1,70 @@
1SUMMARY = "Universal Addresses to RPC Program Number Mapper"
2DESCRIPTION = "The rpcbind utility is a server that converts RPC \
3 program numbers into universal addresses."
4SECTION = "console/network"
5HOMEPAGE = "http://sourceforge.net/projects/rpcbind/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751"
7DEPENDS = "libtirpc quota"
8
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
11 file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
14 file://init.d \
15 file://remove-sys-queue.patch \
16 ${UCLIBCPATCHES} \
17 ${MUSLPATCHES} \
18 file://rpcbind.conf \
19 file://rpcbind.socket \
20 file://rpcbind.service \
21 "
22MUSLPATCHES_libc-musl = "file://musl-sunrpc.patch"
23
24UCLIBCPATCHES ?= ""
25MUSLPATCHES ?= ""
26
27SRC_URI[md5sum] = "cf10cd41ed8228fc54c316191c1f07fe"
28SRC_URI[sha256sum] = "074a9a530dc7c11e0d905aa59bcb0847c009313f02e98d3d798aa9568f414c66"
29
30inherit autotools update-rc.d systemd pkgconfig
31
32PACKAGECONFIG ??= "tcp-wrappers"
33PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
34
35INITSCRIPT_NAME = "rpcbind"
36INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
37
38SYSTEMD_SERVICE_${PN} = "rpcbind.service"
39
40inherit useradd
41
42USERADD_PACKAGES = "${PN}"
43USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \
44 --shell /bin/false --user-group rpc"
45
46PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
47PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \
48 --without-systemdsystemunitdir, \
49 systemd \
50"
51
52EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc"
53
54do_install_append () {
55 mv ${D}${bindir} ${D}${sbindir}
56
57 install -d ${D}${sysconfdir}/init.d
58 sed -e 's,/etc/,${sysconfdir}/,g' \
59 -e 's,/sbin/,${sbindir}/,g' \
60 ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
61 chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
62
63 install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}
64 install -d ${D}${systemd_unitdir}/system
65 install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system
66 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
67 sed -i -e 's,@SBINDIR@,${sbindir},g' \
68 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
69 ${D}${systemd_unitdir}/system/rpcbind.service
70}