diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2023-09-17 11:38:55 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2023-09-18 08:53:10 +0100 |
commit | 556ac3ec46ffaf635d12e29778b30dcab298efdc (patch) | |
tree | 675a7ec0263853fccbb99790a29e213651b7b5f4 /meta/recipes-extended/procps/procps_4.0.3.bb | |
parent | 3737699cf8b8eabc386af6d46c01f0dfe540482f (diff) | |
download | poky-556ac3ec46ffaf635d12e29778b30dcab298efdc.tar.gz |
procps: update 4.0.3 -> 4.0.4
Drop patches as all issues resolved upstream; one of them is a CVE backport.
(From OE-Core rev: 8b5f6565a16bd17cf0cce62d5e7438a01e0cc1c3)
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/procps/procps_4.0.3.bb')
-rw-r--r-- | meta/recipes-extended/procps/procps_4.0.3.bb | 100 |
1 files changed, 0 insertions, 100 deletions
diff --git a/meta/recipes-extended/procps/procps_4.0.3.bb b/meta/recipes-extended/procps/procps_4.0.3.bb deleted file mode 100644 index 9ef679c6bd..0000000000 --- a/meta/recipes-extended/procps/procps_4.0.3.bb +++ /dev/null | |||
@@ -1,100 +0,0 @@ | |||
1 | SUMMARY = "System and process monitoring utilities" | ||
2 | DESCRIPTION = "Procps contains a set of system utilities that provide system information about processes using \ | ||
3 | the /proc filesystem. The package includes the programs ps, top, vmstat, w, kill, and skill." | ||
4 | HOMEPAGE = "https://gitlab.com/procps-ng/procps" | ||
5 | SECTION = "base" | ||
6 | LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
8 | file://COPYING.LIB;md5=4cf66a4984120007c9881cc871cf49db \ | ||
9 | " | ||
10 | |||
11 | DEPENDS = "ncurses" | ||
12 | |||
13 | inherit autotools gettext pkgconfig update-alternatives | ||
14 | |||
15 | SRC_URI = "git://gitlab.com/procps-ng/procps.git;protocol=https;branch=master \ | ||
16 | file://sysctl.conf \ | ||
17 | file://0001-src-w.c-use-utmp.h-only.patch \ | ||
18 | file://0001-po-fr.po-address-failures-with-gettext-0.22.patch \ | ||
19 | file://CVE-2023-4016.patch \ | ||
20 | " | ||
21 | SRCREV = "806eb270f217ff7e1e745c7bda2b002b5be74be4" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | # Upstream has a custom autogen.sh which invokes po/update-potfiles as they | ||
26 | # don't ship a po/POTFILES.in (which is silly). Without that file gettext | ||
27 | # doesn't believe po/ is a gettext directory and won't generate po/Makefile. | ||
28 | do_configure:prepend() { | ||
29 | ( cd ${S} && po/update-potfiles ) | ||
30 | } | ||
31 | |||
32 | EXTRA_OECONF = "--enable-skill --disable-modern-top" | ||
33 | |||
34 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | ||
35 | PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" | ||
36 | |||
37 | do_install:append () { | ||
38 | install -d ${D}${base_bindir} | ||
39 | [ "${bindir}" != "${base_bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i; done | ||
40 | install -d ${D}${base_sbindir} | ||
41 | [ "${sbindir}" != "${base_sbindir}" ] && for i in ${base_sbindir_progs}; do mv ${D}${sbindir}/$i ${D}${base_sbindir}/$i; done | ||
42 | if [ "${base_sbindir}" != "${sbindir}" ]; then | ||
43 | rmdir ${D}${sbindir} | ||
44 | fi | ||
45 | |||
46 | install -d ${D}${sysconfdir} | ||
47 | install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf | ||
48 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
49 | install -d ${D}${sysconfdir}/sysctl.d | ||
50 | ln -sf ../sysctl.conf ${D}${sysconfdir}/sysctl.d/99-sysctl.conf | ||
51 | fi | ||
52 | } | ||
53 | |||
54 | CONFFILES:${PN} = "${sysconfdir}/sysctl.conf" | ||
55 | |||
56 | bindir_progs = "free pkill pmap pgrep pwdx skill snice top uptime w" | ||
57 | base_bindir_progs += "kill pidof ps watch" | ||
58 | base_sbindir_progs += "sysctl" | ||
59 | |||
60 | ALTERNATIVE_PRIORITY = "200" | ||
61 | ALTERNATIVE_PRIORITY[pidof] = "150" | ||
62 | |||
63 | ALTERNATIVE:${PN} = "${bindir_progs} ${base_bindir_progs} ${base_sbindir_progs}" | ||
64 | |||
65 | ALTERNATIVE:${PN}-doc = "kill.1 uptime.1" | ||
66 | ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1" | ||
67 | ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1" | ||
68 | |||
69 | python __anonymous() { | ||
70 | for prog in d.getVar('base_bindir_progs').split(): | ||
71 | d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir'), prog)) | ||
72 | |||
73 | for prog in d.getVar('base_sbindir_progs').split(): | ||
74 | d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_sbindir'), prog)) | ||
75 | } | ||
76 | |||
77 | PROCPS_PACKAGES = "${PN}-lib \ | ||
78 | ${PN}-ps \ | ||
79 | ${PN}-sysctl" | ||
80 | |||
81 | PACKAGE_BEFORE_PN = "${PROCPS_PACKAGES}" | ||
82 | RDEPENDS:${PN} += "${PROCPS_PACKAGES}" | ||
83 | |||
84 | RDEPENDS:${PN}-ps += "${PN}-lib" | ||
85 | RDEPENDS:${PN}-sysctl += "${PN}-lib" | ||
86 | |||
87 | FILES:${PN}-lib = "${libdir}" | ||
88 | FILES:${PN}-ps = "${base_bindir}/ps.${BPN}" | ||
89 | FILES:${PN}-sysctl = "${base_sbindir}/sysctl.${BPN} ${sysconfdir}/sysctl.conf ${sysconfdir}/sysctl.d" | ||
90 | |||
91 | ALTERNATIVE:${PN}:remove = "ps" | ||
92 | ALTERNATIVE:${PN}:remove = "sysctl" | ||
93 | |||
94 | ALTERNATIVE:${PN}-ps = "ps" | ||
95 | ALTERNATIVE_TARGET[ps] = "${base_bindir}/ps" | ||
96 | ALTERNATIVE_LINK_NAME[ps] = "${base_bindir}/ps" | ||
97 | |||
98 | ALTERNATIVE:${PN}-sysctl = "sysctl" | ||
99 | ALTERNATIVE_TARGET[sysctl] = "${base_sbindir}/sysctl" | ||
100 | ALTERNATIVE_LINK_NAME[sysctl] = "${base_sbindir}/sysctl" | ||