diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2015-12-14 16:18:42 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-12-16 12:12:18 +0000 |
commit | d8608bc43400c973db78b022d85019068738a72f (patch) | |
tree | 889867bcac0b75b09cf8e9bd9fec5649d00daeb8 /meta/recipes-extended/procps/procps_3.3.11.bb | |
parent | 52f6a018b7c5e8e824579eda459bca4858f6e36a (diff) | |
download | poky-d8608bc43400c973db78b022d85019068738a72f.tar.gz |
procps: update to 3.3.11
fix-configure.patch was fixing lines that have been removed upstream.
(From OE-Core rev: 42d0699c19b935ce1553d5b88577e1231315d5cc)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/procps/procps_3.3.11.bb')
-rw-r--r-- | meta/recipes-extended/procps/procps_3.3.11.bb | 66 |
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.3.11.bb b/meta/recipes-extended/procps/procps_3.3.11.bb new file mode 100644 index 0000000000..c6dccc6774 --- /dev/null +++ b/meta/recipes-extended/procps/procps_3.3.11.bb | |||
@@ -0,0 +1,66 @@ | |||
1 | SUMMARY = "System and process monitoring utilities" | ||
2 | DESCRIPTION = "Procps contains a set of system utilities that provide system information about processes using \ | ||
3 | the /proc filesystem. The package includes the programs ps, top, vmstat, w, kill, and skill." | ||
4 | HOMEPAGE = "https://gitorious.org/procps" | ||
5 | SECTION = "base" | ||
6 | LICENSE = "GPLv2+ & LGPLv2+" | ||
7 | LIC_FILES_CHKSUM="file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
8 | file://COPYING.LIB;md5=4cf66a4984120007c9881cc871cf49db \ | ||
9 | " | ||
10 | |||
11 | DEPENDS = "ncurses" | ||
12 | |||
13 | inherit autotools gettext pkgconfig update-alternatives | ||
14 | |||
15 | SRC_URI = "http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-${PV}.tar.xz \ | ||
16 | file://sysctl.conf \ | ||
17 | " | ||
18 | |||
19 | SRC_URI[md5sum] = "6cc5b94c1c5b8cbc89ad345a7b522f74" | ||
20 | SRC_URI[sha256sum] = "e9493169a2d2adc0bc045538707310c8e877b385e4e296143b62607d2bb044ed" | ||
21 | |||
22 | S = "${WORKDIR}/procps-ng-${PV}" | ||
23 | |||
24 | EXTRA_OECONF = "--enable-skill --disable-modern-top" | ||
25 | |||
26 | CPPFLAGS += "-I${S}" | ||
27 | |||
28 | do_install_append () { | ||
29 | install -d ${D}${base_bindir} | ||
30 | [ "${bindir}" != "${base_bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i; done | ||
31 | install -d ${D}${base_sbindir} | ||
32 | [ "${sbindir}" != "${base_sbindir}" ] && for i in ${base_sbindir_progs}; do mv ${D}${sbindir}/$i ${D}${base_sbindir}/$i; done | ||
33 | if [ "${base_sbindir}" != "${sbindir}" ]; then | ||
34 | rmdir ${D}${sbindir} | ||
35 | fi | ||
36 | |||
37 | install -d ${D}${sysconfdir} | ||
38 | install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf | ||
39 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
40 | install -d ${D}${sysconfdir}/sysctl.d | ||
41 | ln -sf ../sysctl.conf ${D}${sysconfdir}/sysctl.d/99-sysctl.conf | ||
42 | fi | ||
43 | } | ||
44 | |||
45 | CONFFILES_${PN} = "${sysconfdir}/sysctl.conf" | ||
46 | |||
47 | bindir_progs = "free pkill pmap pgrep pwdx skill snice top uptime" | ||
48 | base_bindir_progs += "kill pidof ps watch" | ||
49 | base_sbindir_progs += "sysctl" | ||
50 | |||
51 | ALTERNATIVE_PRIORITY = "200" | ||
52 | |||
53 | ALTERNATIVE_${PN} = "${bindir_progs} ${base_bindir_progs} ${base_sbindir_progs}" | ||
54 | |||
55 | ALTERNATIVE_${PN}-doc = "kill.1 uptime.1" | ||
56 | ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1" | ||
57 | ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1" | ||
58 | |||
59 | python __anonymous() { | ||
60 | for prog in d.getVar('base_bindir_progs', True).split(): | ||
61 | d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog)) | ||
62 | |||
63 | for prog in d.getVar('base_sbindir_progs', True).split(): | ||
64 | d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_sbindir', True), prog)) | ||
65 | } | ||
66 | |||