summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/procps/procps_3.2.8.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/procps/procps_3.2.8.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/procps/procps_3.2.8.bb')
-rw-r--r--meta/recipes-extended/procps/procps_3.2.8.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb
new file mode 100644
index 0000000000..00632c32bb
--- /dev/null
+++ b/meta/recipes-extended/procps/procps_3.2.8.bb
@@ -0,0 +1,36 @@
1require procps.inc
2
3PR = "r11"
4
5SRC_URI += "file://procmodule.patch \
6 file://psmodule.patch \
7 file://linux-limits.patch \
8 file://sysctl.conf \
9 file://procps-3.2.8+gmake-3.82.patch \
10 file://gnu-kbsd-version.patch \
11 file://60_linux_version_init.patch \
12 file://procps-3.2.7-top-remcpu.patch \
13 file://procps-3.2.8-ps-cgroup.patch \
14 "
15
16SRC_URI[md5sum] = "9532714b6846013ca9898984ba4cd7e0"
17SRC_URI[sha256sum] = "11ed68d8a4433b91cd833deb714a3aa849c02aea738c42e6b4557982419c1535"
18
19EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -I${STAGING_INCDIR}" \
20 CPPFLAGS=-I${STAGING_INCDIR} \
21 LDFLAGS="${LDFLAGS}" \
22 CURSES=-lncurses \
23 install="install -D" \
24 ldconfig=echo'
25
26EXTRA_OEMAKE_append_p2041rdb = ' m64=-m32'
27EXTRA_OEMAKE_append_p4080ds = ' m64=-m32'
28EXTRA_OEMAKE_append_qemuppc = ' m64=-m32'
29
30
31do_install_append () {
32 install -d ${D}${sysconfdir}
33 install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf
34}
35
36CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"