summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pixz/pixz_1.0.6.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 12:58:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:34 +0000
commitb54fa253104c6fec402f8b678337293589cc0545 (patch)
tree7708a32054230cad9f82d6f82daa32740fb849d3 /meta/recipes-extended/pixz/pixz_1.0.6.bb
parentd47572d3dd7ac442bd18205e8f740f2542814a23 (diff)
downloadpoky-b54fa253104c6fec402f8b678337293589cc0545.tar.gz
pixz: Add 1.0.6
xz gives better compression results than bzip/gz but is often slower. Using parallel compression mitigates this somewhat and is particularly useful for the SDK. Whilst xz does have some parallel support, pixz appears to perform better and supports parallel decompression as well as a simpler command line. (From OE-Core rev: b65ab3a38093023310b2f17251b27471cf857561) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pixz/pixz_1.0.6.bb')
-rw-r--r--meta/recipes-extended/pixz/pixz_1.0.6.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/pixz/pixz_1.0.6.bb b/meta/recipes-extended/pixz/pixz_1.0.6.bb
new file mode 100644
index 0000000000..492b7ef611
--- /dev/null
+++ b/meta/recipes-extended/pixz/pixz_1.0.6.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Parallel, indexed xz compressor"
2
3DEPENDS = "xz libarchive"
4DEEPNDS_class-native = "xz-replacement-native libarchive-native"
5
6SRC_URI = "https://github.com/vasi/pixz/releases/download/v${PV}/${BPN}-${PV}.tar.xz"
7SRC_URI[md5sum] = "f6dc5909c9a31b192f69aa397ae8df48"
8SRC_URI[sha256sum] = "02c50746b134fa1b1aae41fcc314d7c6f1919b3d48bcdea01bf11769f83f72e8"
9
10LICENSE = "BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=5cf6d164086105f1512ccb81bfff1926"
12
13SRC_URI += "file://936d8068ae19d95260d3058f41dd6cf718101cd6.patch"
14
15EXTRA_OECONF += "--without-manpage"
16
17CACHED_CONFIGUREVARS += "ac_cv_file_src_pixz_1=no"
18
19inherit autotools pkgconfig
20
21PKG_CONFIG_PATH_append_class-native = ":${STAGING_DIR_HOST}${libdir}/xz-native/pkgconfig"
22BUILD_LDFLAGS_append_class-native = " -Wl,-rpath,${STAGING_DIR_HOST}${libdir}/xz-native/"
23
24BBCLASSEXTEND = "native"