summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pigz/pigz_2.4.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-02-01 01:20:42 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 11:06:28 +0000
commit5a74a370ed29821cca2788cc9a7df440a93e916e (patch)
treebaa8bbd370ae2c7c1a4ad4524f0d17df4623db67 /meta/recipes-extended/pigz/pigz_2.4.bb
parent232d382d178672156ba945783a26c84422860a28 (diff)
downloadpoky-5a74a370ed29821cca2788cc9a7df440a93e916e.tar.gz
pigz: 2.3.4 -> 2.4
License-checksum-change: license is no change, only version bump up. https://github.com/madler/pigz/commit/fe822cb435622c43f491013da77b127e9fe851a9 (From OE-Core rev: efa166021d2520b3badfdc44968ee618c65be705) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pigz/pigz_2.4.bb')
-rw-r--r--meta/recipes-extended/pigz/pigz_2.4.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/pigz/pigz_2.4.bb b/meta/recipes-extended/pigz/pigz_2.4.bb
new file mode 100644
index 0000000000..cb41154daf
--- /dev/null
+++ b/meta/recipes-extended/pigz/pigz_2.4.bb
@@ -0,0 +1,49 @@
1SUMMARY = "A parallel implementation of gzip"
2DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \
3fully functional replacement for gzip that exploits multiple processors and \
4multiple cores to the hilt when compressing data. pigz was written by Mark \
5Adler, and uses the zlib and pthread libraries."
6HOMEPAGE = "http://zlib.net/pigz/"
7SECTION = "console/utils"
8LICENSE = "Zlib & Apache-2.0"
9LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21"
10
11PROVIDES_class-native += "gzip-native"
12
13SRC_URI = "https://github.com/madler/pigz/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
14SRC_URI[md5sum] = "3c8a601db141d3013ef9fe5f2daaf73f"
15SRC_URI[sha256sum] = "e228e7d18b34c4ece8d596eb6eee97bde533c6beedbb728d07d3abe90b4b1b52"
16
17UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/"
18UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar"
19
20DEPENDS = "zlib"
21
22EXTRA_OEMAKE = "-e MAKEFLAGS="
23
24inherit update-alternatives
25
26do_install_class-target() {
27 # Install files into /bin (FHS), which is typical place for gzip
28 install -d ${D}${base_bindir}
29 install ${B}/pigz ${D}${base_bindir}/pigz
30 ln -nsf pigz ${D}${base_bindir}/unpigz
31 ln -nsf pigz ${D}${base_bindir}/pigzcat
32}
33
34do_install() {
35 install -d ${D}${bindir}
36 install ${B}/pigz ${D}${bindir}/gzip
37 ln -nsf gzip ${D}${bindir}/gunzip
38 ln -nsf gzip ${D}${bindir}/zcat
39}
40
41ALTERNATIVE_PRIORITY = "80"
42ALTERNATIVE_${PN} = "gunzip gzip zcat"
43ALTERNATIVE_${PN}_class-nativesdk = ""
44ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
45ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
46ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
47ALTERNATIVE_TARGET = "${base_bindir}/pigz"
48
49BBCLASSEXTEND = "native nativesdk"