summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-29 00:39:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:02 +0100
commit66baf90a884fe5b39a9fe837c85b49bf9eaac3ae (patch)
tree5de697edff4a5da9075384040d58dadccec7257d /meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
parent602c7d65bb1d3f19b99b4f950442f298025f2104 (diff)
downloadpoky-66baf90a884fe5b39a9fe837c85b49bf9eaac3ae.tar.gz
libxml-sax-perl: upgrade 0.99 -> 1.00
Upstream release notes: 1.00 15 Feb 2018 Grant McLean - Add makefile dependency to fix order of build steps RT#62289 (patch from Ed J) (From OE-Core rev: d11d124ed641aac9934433116e4b7a2b1806d79b) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-sax-perl_1.00.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_1.00.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb b/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
new file mode 100644
index 0000000000..141830efe8
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
2HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/"
3DESCRIPTION = "XML::SAX consists of several framework classes for using and \
4building Perl SAX2 XML parsers, filters, and drivers. It is designed \
5around the need to be able to "plug in" different SAX parsers to an \
6application without requiring programmer intervention. Those of you \
7familiar with the DBI will be right at home. Some of the designs \
8come from the Java JAXP specification (SAX part), only without the \
9javaness."
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13DEPENDS += "libxml-namespacesupport-perl-native"
14RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "861a454f7bf269990ed2c1c125f4db48"
21SRC_URI[sha256sum] = "45ea6564ef8692155d57b2de0862b6442d3c7e29f4a9bc9ede5d7ecdc74c2ae3"
22
23S = "${WORKDIR}/XML-SAX-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_ptest() {
28 cp -r ${B}/testfiles ${D}${PTEST_PATH}
29 chown -R root:root ${D}${PTEST_PATH}/testfiles
30}
31
32BBCLASSEXTEND = "native"