summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-23 01:17:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-28 12:09:51 +0100
commitfbf3b0cab7fd072df56043fc4587001147b7b993 (patch)
tree51b353c4511531e770442a295c445d4e3f0327f7 /meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
parent044ad48c53ded84a636f4e7e3c9903fff22b7b83 (diff)
downloadpoky-fbf3b0cab7fd072df56043fc4587001147b7b993.tar.gz
libxml-namespacesupport: use stable v1.12 release; inherit ptest-perl
* Fix RDEPENDS * Upstream v1.12_9 is a development version, not a stable release * Add UPSTREAM_CHECK_REGEX skip development releases * Drop anonymous python function to "fix" version, which breaks auto-upgrade-helper (AUH) * Use LICENSE file for checksum rather than ephemeral META.yml * License remains the same Fixes: [YOCTO #12581] License-Update: use LICENSE file for checksum (From OE-Core rev: 613fa79adff798e29ec7f72bff6f060a1832bc89) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
new file mode 100644
index 0000000000..fa9f9954bb
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Perl module for supporting simple generic namespaces"
2HOMEPAGE = "http://veillard.com/XML/"
3DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-based XML names. \
4 It also helps maintain a prefix-to-namespace URI map, and provides a number of \
5 basic checks. "
6
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10SRCNAME = "XML-NamespaceSupport"
11
12LIC_FILES_CHKSUM = "file://LICENSE;md5=c9d8a117e7620b5adf8d69c29613ceab"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/P/PE/PERIGRIN/${SRCNAME}-${PV}.tar.gz"
15SRC_URI[md5sum] = "a8916c6d095bcf073e1108af02e78c97"
16SRC_URI[sha256sum] = "47e995859f8dd0413aa3f22d350c4a62da652e854267aa0586ae544ae2bae5ef"
17
18UPSTREAM_CHECK_REGEX = "XML\-NamespaceSupport\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
19
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit cpan ptest-perl
23
24RDEPENDS_${PN}-ptest += "perl-module-test-more"
25
26BBCLASSEXTEND="native"
27