diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2022-05-05 07:05:16 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-05-05 21:17:38 +0100 |
commit | dc4ac7877c0ca71d2a89583c3f2f2836e7da6005 (patch) | |
tree | 3a6103bd56d8557d36a551219edd4c339859a5b3 /meta/recipes-extended/parted/parted_3.5.bb | |
parent | 3704331fc673c8686165f7ad7670c20a4104d8eb (diff) | |
download | poky-dc4ac7877c0ca71d2a89583c3f2f2836e7da6005.tar.gz |
parted: upgrade 3.4 -> 3.5
(From OE-Core rev: 68a3a770b7ecd8b29fa08908d6cef86d90eb6111)
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.5.bb')
-rw-r--r-- | meta/recipes-extended/parted/parted_3.5.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.5.bb b/meta/recipes-extended/parted/parted_3.5.bb new file mode 100644 index 0000000000..ea2b68bbd8 --- /dev/null +++ b/meta/recipes-extended/parted/parted_3.5.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | SUMMARY = "Disk partition editing/resizing utility" | ||
2 | HOMEPAGE = "http://www.gnu.org/software/parted/parted.html" | ||
3 | DESCRIPTION = "GNU Parted manipulates partition tables. This is useful for creating space for new operating systems, reorganizing disk usage, copying data on hard disks and disk imaging." | ||
4 | LICENSE = "GPL-3.0-or-later" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c" | ||
6 | SECTION = "console/tools" | ||
7 | DEPENDS = "ncurses util-linux virtual/libiconv" | ||
8 | |||
9 | SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \ | ||
10 | file://fix-doc-mandir.patch \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[sha256sum] = "4938dd5c1c125f6c78b1f4b3e297526f18ee74aa43d45c248578b1d2470c05a2" | ||
15 | |||
16 | inherit autotools pkgconfig gettext texinfo ptest | ||
17 | |||
18 | PACKAGECONFIG ?= "readline" | ||
19 | PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,libdevmapper lvm2" | ||
20 | PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline" | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
23 | |||
24 | do_compile_ptest() { | ||
25 | oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags | ||
26 | } | ||
27 | |||
28 | do_install_ptest() { | ||
29 | t=${D}${PTEST_PATH} | ||
30 | mkdir $t/build-aux | ||
31 | cp ${S}/build-aux/test-driver $t/build-aux/ | ||
32 | cp -r ${S}/tests $t | ||
33 | cp ${B}/tests/Makefile $t/tests/ | ||
34 | mkdir $t/lib | ||
35 | cp ${B}/lib/config.h $t/lib | ||
36 | sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile | ||
37 | sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile | ||
38 | sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile | ||
39 | sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = "${PTEST_PATH}"|g" $t/tests/Makefile | ||
40 | sed -i "s|^abs_top_builddir =.*|abs_top_builddir = "${PTEST_PATH}"|g" $t/tests/Makefile | ||
41 | sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile | ||
42 | sed -i "/^BUILDINFO.*$/d" $t/tests/Makefile | ||
43 | for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \ | ||
44 | do cp ${B}/tests/.libs/$i $t/tests/; \ | ||
45 | done | ||
46 | sed -e 's| ../parted||' -i $t/tests/*.sh | ||
47 | } | ||
48 | |||
49 | RDEPENDS:${PN}-ptest = "bash coreutils perl util-linux-losetup util-linux-mkswap python3 make gawk e2fsprogs-mke2fs e2fsprogs-tune2fs python3-core dosfstools" | ||
50 | RRECOMMENDS:${PN}-ptest += "kernel-module-scsi-debug kernel-module-loop kernel-module-vfat" | ||
51 | RDEPENDS:${PN}-ptest:append:libc-glibc = "\ | ||
52 | glibc-utils \ | ||
53 | locale-base-en-us \ | ||
54 | " | ||
55 | |||
56 | inherit update-alternatives | ||
57 | |||
58 | ALTERNATIVE_PRIORITY = "100" | ||
59 | ALTERNATIVE:${PN} = "partprobe" | ||
60 | ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe" | ||