diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2019-12-12 19:14:24 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-12-16 23:25:49 +0000 |
commit | 634264a924288d5c48c4f26af0dfdf017a7b0f62 (patch) | |
tree | af615fe754b407e602aceeba60cc1aa9629c0697 /meta/recipes-extended/parted/parted_3.3.bb | |
parent | d62895e112e25f72308cb31f70aeb16d7eefb008 (diff) | |
download | poky-634264a924288d5c48c4f26af0dfdf017a7b0f62.tar.gz |
parted: update 3.2->3.3
0001-Unset-need_charset_alias-when-building-for-musl.patch is no longer
necessary as upstream has removed the code.
dm_check.patch is replaced with 0002-tests-use-skip_-rather-than-skip_test_-which-is-unde.patch
Rework ptests, in particular remove the generated Makefile
from the layer, and use the upstream Makefile.
Ptest pass rate is 100%.
(From OE-Core rev: 5dc6529d0b5b8b1bef12b90008f0a25612bd453e)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.3.bb')
-rw-r--r-- | meta/recipes-extended/parted/parted_3.3.bb | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.3.bb b/meta/recipes-extended/parted/parted_3.3.bb new file mode 100644 index 0000000000..1cfd9ec264 --- /dev/null +++ b/meta/recipes-extended/parted/parted_3.3.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | SUMMARY = "Disk partition editing/resizing utility" | ||
2 | HOMEPAGE = "http://www.gnu.org/software/parted/parted.html" | ||
3 | LICENSE = "GPLv3+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c" | ||
5 | SECTION = "console/tools" | ||
6 | DEPENDS = "ncurses readline util-linux virtual/libiconv" | ||
7 | |||
8 | SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \ | ||
9 | file://no_check.patch \ | ||
10 | file://fix-doc-mandir.patch \ | ||
11 | file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \ | ||
12 | file://0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch \ | ||
13 | file://run-ptest \ | ||
14 | file://0001-libparted-fs-add-sourcedir-lib-to-include-paths.patch \ | ||
15 | file://0002-tests-use-skip_-rather-than-skip_test_-which-is-unde.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "090655d05f3c471aa8e15a27536889ec" | ||
19 | SRC_URI[sha256sum] = "57e2b4bd87018625c515421d4524f6e3b55175b472302056391c5f7eccb83d44" | ||
20 | |||
21 | EXTRA_OECONF = "--disable-device-mapper" | ||
22 | |||
23 | inherit autotools pkgconfig gettext texinfo ptest | ||
24 | |||
25 | BBCLASSEXTEND = "native" | ||
26 | |||
27 | do_compile_ptest() { | ||
28 | oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags | ||
29 | } | ||
30 | |||
31 | do_install_ptest() { | ||
32 | t=${D}${PTEST_PATH} | ||
33 | mkdir $t/build-aux | ||
34 | cp ${S}/build-aux/test-driver $t/build-aux/ | ||
35 | cp -r ${S}/tests $t | ||
36 | cp ${B}/tests/Makefile $t/tests/ | ||
37 | sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile | ||
38 | sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile | ||
39 | sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile | ||
40 | sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile | ||
41 | sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile | ||
42 | for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \ | ||
43 | do cp ${B}/tests/.libs/$i $t/tests/; \ | ||
44 | done | ||
45 | sed -e 's| ../parted||' -i $t/tests/*.sh | ||
46 | } | ||
47 | |||
48 | RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs" | ||
49 | |||
50 | RDEPENDS_${PN}-ptest_append_libc-glibc = "\ | ||
51 | glibc-utils \ | ||
52 | locale-base-en-us \ | ||
53 | " | ||
54 | |||
55 | inherit update-alternatives | ||
56 | |||
57 | ALTERNATIVE_PRIORITY = "100" | ||
58 | ALTERNATIVE_${PN} = "partprobe" | ||
59 | ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe" | ||