diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2018-03-01 10:11:38 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-03-04 11:35:41 +0000 |
commit | a51236a2441c33558568b649f7ca0363856697f7 (patch) | |
tree | f1b7b87b6867dd935c554aed2e6c45542e3a3ec0 /meta/recipes-extended/pam/libpam_1.3.0.bb | |
parent | 52de574e0db0a7c5cce9681ac68fe488d5d029d2 (diff) | |
download | poky-a51236a2441c33558568b649f7ca0363856697f7.tar.gz |
libpam: be more strict about user's sanity
* replace do_pam_sanity function with distro_features_check inherit
* fixes:
WARNING: libpam-1.3.0-r5 do_pam_sanity: Building libpam but 'pam' isn't in DISTRO_FEATURES, PAM won't work correctly
in world builds and prevents user to build libpam at all without pam
in DISTRO_FEATURES, I don't see any users of this which wouldn't respect
pam in DISTRO_FEATURES
* only libuser is depending on libpam without respecting DISTRO_FEATURES
* there are few recipes in meta-oe layers depending on libpam without
respecting DISTRO_FEATURES, I've sent patch for them:
samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs
and omxplayer in meta-raspberrypi, I've sent PR for that one:
https://github.com/agherzan/meta-raspberrypi/pull/192
* poky-lsb will need to add pam to DISTRO_FEATURES in order to build
packagegroup-core-lsb
(From OE-Core rev: c9e7a276859d38aaa03845ee09428f62760ad147)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.3.0.bb')
-rw-r--r-- | meta/recipes-extended/pam/libpam_1.3.0.bb | 7 |
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.3.0.bb b/meta/recipes-extended/pam/libpam_1.3.0.bb index 8f7753d001..92ab72a42f 100644 --- a/meta/recipes-extended/pam/libpam_1.3.0.bb +++ b/meta/recipes-extended/pam/libpam_1.3.0.bb | |||
@@ -151,11 +151,8 @@ do_install() { | |||
151 | fi | 151 | fi |
152 | } | 152 | } |
153 | 153 | ||
154 | python do_pam_sanity () { | 154 | inherit distro_features_check |
155 | if not bb.utils.contains('DISTRO_FEATURES', 'pam', True, False, d): | 155 | REQUIRED_DISTRO_FEATURES = "pam" |
156 | bb.warn("Building libpam but 'pam' isn't in DISTRO_FEATURES, PAM won't work correctly") | ||
157 | } | ||
158 | addtask pam_sanity before do_configure | ||
159 | 156 | ||
160 | BBCLASSEXTEND = "nativesdk native" | 157 | BBCLASSEXTEND = "nativesdk native" |
161 | 158 | ||