summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.1.4.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-01-12 14:11:49 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-17 14:53:23 +0000
commit6ce82eac3b398816f7c11dbfa90d24517a792839 (patch)
treeb8ba410aa662b1f771366e1b406b6d81d95ff7d7 /meta/recipes-extended/pam/libpam_1.1.4.bb
parent35759f977eec6ef81e125a509a7148d7e53a6515 (diff)
downloadpoky-6ce82eac3b398816f7c11dbfa90d24517a792839.tar.gz
libpam: upgrade to 1.1.5
Updated HOMEPAGE, BUGTRACKER, and SRC_URI fields to reflect new project hosting. Cleaned up some of the metadata ordering. (From OE-Core rev: 1fcd483e5ee5223f37c5edce26327f79b76bd01d) Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.4.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.4.bb93
1 files changed, 0 insertions, 93 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.4.bb b/meta/recipes-extended/pam/libpam_1.1.4.bb
deleted file mode 100644
index afe17cc932..0000000000
--- a/meta/recipes-extended/pam/libpam_1.1.4.bb
+++ /dev/null
@@ -1,93 +0,0 @@
1SUMMARY = "Linux-PAM (Pluggable Authentication Modules)"
2DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), Basically, it is a flexible mechanism for authenticating users"
3HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/"
4BUGTRACKER = "http://sourceforge.net/projects/pam/support"
5SECTION = "base"
6# PAM is dual licensed under GPL and BSD.
7# /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time
8# libpam-runtime-1.0.1 is GPLv2+), by openembedded
9LICENSE = "GPLv2+ | BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
11
12PR = "r2"
13
14DEPENDS = "bison flex flex-native cracklib"
15RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
16RDEPENDS_${PN}-xtests = "libpam pam-plugin-access pam-plugin-debug pam-plugin-cracklib pam-plugin-pwhistory \
17 pam-plugin-succeed-if pam-plugin-time coreutils"
18RRECOMMENDS_${PN} = "libpam-runtime"
19
20SRC_URI = "${KERNELORG_MIRROR}/linux/libs/pam/library/Linux-PAM-${PV}.tar.bz2 \
21 file://99_pam \
22 file://pam.d/* \
23 file://libpam-xtests.patch"
24
25SRC_URI_append_libc-uclibc = " file://pam-no-innetgr.patch"
26
27SRC_URI[md5sum] = "e9af5fb27bb22edb55d077e2888b3ebc"
28SRC_URI[sha256sum] = "ccd89331914390b1e9e99c954471d65f19b660d81e15a46eeb96cee125d44056"
29
30EXTRA_OECONF = "--with-db-uniquename=_pam \
31 --includedir=${includedir}/security \
32 --libdir=${base_libdir} \
33 --disable-regenerate-docu"
34CFLAGS_append = " -fPIC "
35
36S = "${WORKDIR}/Linux-PAM-${PV}"
37
38inherit autotools gettext
39
40PACKAGES += "${PN}-runtime ${PN}-xtests"
41FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"
42FILES_${PN}-dbg += "${base_libdir}/security/.debug \
43 ${base_libdir}/security/pam_filter/.debug \
44 ${datadir}/Linux-PAM/xtests/.debug"
45
46FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}"
47FILES_${PN}-runtime = "${sysconfdir}"
48FILES_${PN}-xtests = "${datadir}/Linux-PAM/xtests"
49
50PACKAGES_DYNAMIC += " pam-plugin-*"
51
52python populate_packages_prepend () {
53 import os.path
54
55 def pam_plugin_append_file(pn, dir, file):
56 nf = os.path.join(dir, file)
57 of = d.getVar('FILES_' + pn, True)
58 if of:
59 nf = of + " " + nf
60 d.setVar('FILES_' + pn, nf)
61
62 dvar = bb.data.expand('${WORKDIR}/package', d, True)
63 pam_libdir = bb.data.expand('${base_libdir}/security', d)
64 pam_sbindir = bb.data.expand('${sbindir}', d)
65 pam_filterdir = bb.data.expand('${base_libdir}/security/pam_filter', d)
66
67 do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
68 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_chkpwd')
69 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_update')
70 pam_plugin_append_file('pam-plugin-tally', pam_sbindir, 'pam_tally')
71 pam_plugin_append_file('pam-plugin-tally2', pam_sbindir, 'pam_tally2')
72 pam_plugin_append_file('pam-plugin-timestamp', pam_sbindir, 'pam_timestamp_check')
73 pam_plugin_append_file('pam-plugin-mkhomedir', pam_sbindir, 'mkhomedir_helper')
74 do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
75}
76
77do_install() {
78 autotools_do_install
79
80 # don't install /var/run when populating rootfs. Do it through volatile
81 rm -rf ${D}/var
82 install -d ${D}${sysconfdir}/default/volatiles
83 install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
84
85 install -d ${D}${sysconfdir}/pam.d/
86 install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
87}
88
89pkg_postinst_pam-plugin-unix () {
90 # below is necessary to allow unix_chkpwd get user info from shadow file
91 # on lsb images
92 chmod 4755 ${sbindir}/unix_chkpwd
93}