diff options
author | Kang Kai <kai.kang@windriver.com> | 2011-07-19 17:08:31 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-07-27 12:02:41 +0100 |
commit | b1a020621cbbfcf5607cdf2ceb78f29082824620 (patch) | |
tree | 8e45c087a9afbff242dccbd36d990e1a16b68229 /meta/recipes-extended/pam/libpam_1.1.4.bb | |
parent | 066f06c978d289fa72bad79635dd9534f68941ca (diff) | |
download | poky-b1a020621cbbfcf5607cdf2ceb78f29082824620.tar.gz |
libpam: update to 1.1.4 and add subpackage xtests
Update libpam to 1.1.4, and add dependecy cracklib because run xtexts will
need pam-plugin-cracklib.
There are some additional checks under subdirectory xtests and make it
as a subpackage libpam-xtests.
(From OE-Core rev: f9158bf219479c2da56dd21a13ecee3176cd6f8a)
Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.4.bb')
-rw-r--r-- | meta/recipes-extended/pam/libpam_1.1.4.bb | 85 |
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.4.bb b/meta/recipes-extended/pam/libpam_1.1.4.bb new file mode 100644 index 0000000000..59fbdcdffc --- /dev/null +++ b/meta/recipes-extended/pam/libpam_1.1.4.bb | |||
@@ -0,0 +1,85 @@ | |||
1 | SUMMARY = "Linux-PAM (Pluggable Authentication Modules)" | ||
2 | DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), Basically, it is a flexible mechanism for authenticating users" | ||
3 | HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/" | ||
4 | BUGTRACKER = "http://sourceforge.net/projects/pam/support" | ||
5 | SECTION = "base" | ||
6 | # PAM is dual licensed under GPL and BSD. | ||
7 | # /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time | ||
8 | # libpam-runtime-1.0.1 is GPLv2+), by openembedded | ||
9 | LICENSE = "GPLv2+ | BSD" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083" | ||
11 | |||
12 | PR = "r0" | ||
13 | |||
14 | DEPENDS = "bison flex cracklib" | ||
15 | RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix" | ||
16 | RDEPENDS_${PN}-xtests = "libpam pam-plugin-access pam-plugin-debug pam-plugin-cracklib pam-plugin-pwhistory \ | ||
17 | pam-plugin-succeed-if pam-plugin-time coreutils" | ||
18 | RRECOMMENDS_${PN} = "libpam-runtime" | ||
19 | |||
20 | SRC_URI = "${KERNELORG_MIRROR}/linux/libs/pam/library/Linux-PAM-${PV}.tar.bz2 \ | ||
21 | file://99_pam \ | ||
22 | file://pam.d/* \ | ||
23 | file://libpam-xtests.patch" | ||
24 | |||
25 | SRC_URI_append_libc-uclibc = " file://pam-no-innetgr.patch" | ||
26 | |||
27 | SRC_URI[md5sum] = "e9af5fb27bb22edb55d077e2888b3ebc" | ||
28 | SRC_URI[sha256sum] = "ccd89331914390b1e9e99c954471d65f19b660d81e15a46eeb96cee125d44056" | ||
29 | |||
30 | EXTRA_OECONF = "--with-db-uniquename=_pam \ | ||
31 | --includedir=${includedir}/security \ | ||
32 | --libdir=${base_libdir} \ | ||
33 | --disable-regenerate-docu" | ||
34 | CFLAGS_append = " -fPIC " | ||
35 | |||
36 | S = "${WORKDIR}/Linux-PAM-${PV}" | ||
37 | |||
38 | inherit autotools gettext | ||
39 | |||
40 | PACKAGES += "${PN}-runtime ${PN}-xtests" | ||
41 | FILES_${PN} = "${base_libdir}/lib*${SOLIBS}" | ||
42 | FILES_${PN}-dbg += "${base_libdir}/security/.debug \ | ||
43 | ${base_libdir}/security/pam_filter/.debug" | ||
44 | FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}" | ||
45 | FILES_${PN}-runtime = "${sysconfdir}" | ||
46 | FILES_${PN}-xtests = "${datadir}/Linux-PAM/xtests" | ||
47 | |||
48 | PACKAGES_DYNAMIC += " pam-plugin-*" | ||
49 | |||
50 | python populate_packages_prepend () { | ||
51 | import os.path | ||
52 | |||
53 | def pam_plugin_append_file(pn, dir, file): | ||
54 | nf = os.path.join(dir, file) | ||
55 | of = bb.data.getVar('FILES_' + pn, d, True) | ||
56 | if of: | ||
57 | nf = of + " " + nf | ||
58 | bb.data.setVar('FILES_' + pn, nf, d) | ||
59 | |||
60 | dvar = bb.data.expand('${WORKDIR}/package', d, True) | ||
61 | pam_libdir = bb.data.expand('${base_libdir}/security', d) | ||
62 | pam_sbindir = bb.data.expand('${sbindir}', d) | ||
63 | pam_filterdir = bb.data.expand('${base_libdir}/security/pam_filter', d) | ||
64 | |||
65 | do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='') | ||
66 | pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_chkpwd') | ||
67 | pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_update') | ||
68 | pam_plugin_append_file('pam-plugin-tally', pam_sbindir, 'pam_tally') | ||
69 | pam_plugin_append_file('pam-plugin-tally2', pam_sbindir, 'pam_tally2') | ||
70 | pam_plugin_append_file('pam-plugin-timestamp', pam_sbindir, 'pam_timestamp_check') | ||
71 | pam_plugin_append_file('pam-plugin-mkhomedir', pam_sbindir, 'mkhomedir_helper') | ||
72 | do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='') | ||
73 | } | ||
74 | |||
75 | do_install() { | ||
76 | autotools_do_install | ||
77 | |||
78 | # don't install /var/run when populating rootfs. Do it through volatile | ||
79 | rm -rf ${D}/var | ||
80 | install -d ${D}${sysconfdir}/default/volatiles | ||
81 | install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles | ||
82 | |||
83 | install -d ${D}${sysconfdir}/pam.d/ | ||
84 | install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/ | ||
85 | } | ||