summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-06 16:46:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 14:45:21 +0000
commit91c372f287732cdedbd7c1204c6ba5f34e5b93f6 (patch)
treec088d751fdbaed6e10c58f92aa8890848c225458 /meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb
parent2f9bf7bc97cb832f4db13df62ce09d96ce75e810 (diff)
downloadpoky-91c372f287732cdedbd7c1204c6ba5f34e5b93f6.tar.gz
core-image-basic / packagegroup-core-basic: rename to *-full-cmdline
This more accurately represents what this image and packagegroup are intended to provide (a more complete command-line environment similar to what you would find on a traditional Linux system), and avoids confusion with the similarly named core-image-base and packagegroup-base. Fixes [YOCTO #2424]. (From OE-Core rev: 959396d5319df6d6599cc74077e85182768b92af) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb163
1 files changed, 163 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb b/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb
new file mode 100644
index 0000000000..b87213cb99
--- /dev/null
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb
@@ -0,0 +1,163 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Standard full-featured Linux system"
6DESCRIPTION = "Package group bringing in packages needed for a more traditional full-featured Linux system"
7PR = "r6"
8LICENSE = "MIT"
9
10inherit packagegroup
11
12PACKAGES = "\
13 packagegroup-core-full-cmdline \
14 packagegroup-core-full-cmdline-libs \
15 packagegroup-core-full-cmdline-utils \
16 packagegroup-core-full-cmdline-extended \
17 packagegroup-core-full-cmdline-dev-utils \
18 packagegroup-core-full-cmdline-multiuser \
19 packagegroup-core-full-cmdline-initscripts \
20 packagegroup-core-full-cmdline-sys-services \
21 "
22
23python __anonymous () {
24 # For backwards compatibility after rename
25 namemap = {}
26 namemap["packagegroup-core-full-cmdline"] = "packagegroup-core-basic"
27 namemap["packagegroup-core-full-cmdline-libs"] = "packagegroup-core-basic-libs"
28 namemap["packagegroup-core-full-cmdline-utils"] = "packagegroup-core-basic-utils"
29 namemap["packagegroup-core-full-cmdline-extended"] = "packagegroup-core-basic-extended"
30 namemap["packagegroup-core-full-cmdline-dev-utils"] = "packagegroup-core-dev-utils"
31 namemap["packagegroup-core-full-cmdline-multiuser"] = "packagegroup-core-multiuser"
32 namemap["packagegroup-core-full-cmdline-initscripts"] = "packagegroup-core-initscripts"
33 namemap["packagegroup-core-full-cmdline-sys-services"] = "packagegroup-core-sys-services"
34
35 packages = d.getVar("PACKAGES", True).split()
36 for pkg in packages:
37 if pkg.endswith('-dev'):
38 mapped = namemap.get(pkg[:-4], None)
39 if mapped:
40 mapped += '-dev'
41 elif pkg.endswith('-dbg'):
42 mapped = namemap.get(pkg[:-4], None)
43 if mapped:
44 mapped += '-dbg'
45 else:
46 mapped = namemap.get(pkg, None)
47
48 if mapped:
49 oldtaskname = mapped.replace("packagegroup-core", "task-core")
50 mapstr = " %s %s" % (mapped, oldtaskname)
51 d.appendVar("RPROVIDES_%s" % pkg, mapstr)
52 d.appendVar("RREPLACES_%s" % pkg, mapstr)
53 d.appendVar("RCONFLICTS_%s" % pkg, mapstr)
54}
55
56
57RDEPENDS_packagegroup-core-full-cmdline = "\
58 packagegroup-core-full-cmdline-libs \
59 packagegroup-core-full-cmdline-utils \
60 packagegroup-core-full-cmdline-extended \
61 packagegroup-core-full-cmdline-dev-utils \
62 packagegroup-core-full-cmdline-multiuser \
63 packagegroup-core-full-cmdline-initscripts \
64 packagegroup-core-full-cmdline-sys-services \
65 "
66
67RDEPENDS_packagegroup-core-full-cmdline-libs = "\
68 glib-2.0 \
69 "
70
71RDEPENDS_packagegroup-core-full-cmdline-utils = "\
72 bash \
73 acl \
74 attr \
75 bc \
76 coreutils \
77 cpio \
78 e2fsprogs \
79 ed \
80 file \
81 findutils \
82 gawk \
83 gmp \
84 grep \
85 makedevs \
86 mc \
87 mc-fish \
88 mc-helpers \
89 mc-helpers-perl \
90 mc-helpers-python \
91 mktemp \
92 ncurses \
93 net-tools \
94 pax \
95 popt \
96 procps \
97 psmisc \
98 sed \
99 tar \
100 time \
101 util-linux \
102 zlib \
103 "
104
105RDEPENDS_packagegroup-core-full-cmdline-extended = "\
106 iproute2 \
107 iputils \
108 iptables \
109 module-init-tools \
110 openssl \
111 "
112
113RDEPENDS_packagegroup-core-full-cmdline-dev-utils = "\
114 byacc \
115 diffutils \
116 m4 \
117 make \
118 patch \
119 "
120
121VIRTUAL-RUNTIME_initscripts ?= "initscripts"
122VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
123VIRTUAL-RUNTIME_login_manager ?= "busybox"
124VIRTUAL-RUNTIME_syslog ?= "sysklogd"
125RDEPENDS_packagegroup-core-full-cmdline-initscripts = "\
126 ${VIRTUAL-RUNTIME_initscripts} \
127 ${VIRTUAL-RUNTIME_init_manager} \
128 ethtool \
129 ${VIRTUAL-RUNTIME_login_manager} \
130 ${VIRTUAL-RUNTIME_syslog} \
131 "
132
133RDEPENDS_packagegroup-core-full-cmdline-multiuser = "\
134 cracklib \
135 gzip \
136 ${@base_contains('DISTRO_FEATURES', 'pam', 'libuser', '', d)} \
137 shadow \
138 sudo \
139 "
140
141RDEPENDS_packagegroup-core-full-cmdline-sys-services = "\
142 at \
143 bzip2 \
144 cronie \
145 dbus \
146 dbus-glib \
147 python-dbus \
148 elfutils \
149 gzip \
150 less \
151 libcap \
152 libevent \
153 lighttpd \
154 logrotate \
155 nfs-utils \
156 pciutils \
157 libpcre \
158 rpcbind \
159 sysfsutils \
160 tcp-wrappers \
161 tzdata \
162 "
163