summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.21.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-08-09 09:48:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-13 09:37:37 +0100
commitd1100db5eb6ae18339dd7944cf9c52238790247b (patch)
tree80a8d2549964fb0e01be0dc999caf370cc3b1d9f /meta/recipes-extended/newt/libnewt_0.52.21.bb
parentd90fb2a87e69df8bdba07227f7a876c501ad93bf (diff)
downloadpoky-d1100db5eb6ae18339dd7944cf9c52238790247b.tar.gz
libnewt:upgrade 0.52.20 -> 0.52.21
-Refresh the following patch: files/pie-flags.patch -files/fix_SHAREDDIR.patch Removed since this is included in 0.52.21. (From OE-Core rev: 5b7fd7a945f8eeece51f01ad20a6de12fea89433) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.21.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.21.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.21.bb b/meta/recipes-extended/newt/libnewt_0.52.21.bb
new file mode 100644
index 0000000000..09b61be61d
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.21.bb
@@ -0,0 +1,58 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt python3"
19
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
21 file://cross_ar.patch \
22 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
23 file://pie-flags.patch \
24 file://0001-detect-gold-as-GNU-linker-too.patch \
25"
26
27SRC_URI[md5sum] = "a0a5fd6b53bb167a65e15996b249ebb5"
28SRC_URI[sha256sum] = "265eb46b55d7eaeb887fca7a1d51fe115658882dfe148164b6c49fccac5abb31"
29
30S = "${WORKDIR}/newt-${PV}"
31
32inherit autotools-brokensep python3native python3-dir
33
34EXTRA_OECONF = "--without-tcl --with-python"
35
36EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
37
38CLEANBROKEN = "1"
39
40export CPPFLAGS
41
42PACKAGES_prepend = "whiptail ${PN}-python "
43
44RDEPENDS_${PN}-python += "python3-core"
45FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
46
47do_configure_prepend() {
48 sh autogen.sh
49}
50
51do_compile_prepend() {
52 # Make sure the recompile is OK
53 rm -f ${B}/.depend
54}
55
56FILES_whiptail = "${bindir}/whiptail"
57
58BBCLASSEXTEND = "native nativesdk"