summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.19.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2016-06-13 05:16:31 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:02 +0100
commit4e5128b5e47315c9318f2fd6e74112ddcc998ece (patch)
tree3c1ce22b7a919334e3c3cef5551355939ab2cd29 /meta/recipes-extended/newt/libnewt_0.52.19.bb
parentf81a018089f9b92d08b6a0333c9fb75b9e6824e2 (diff)
downloadpoky-4e5128b5e47315c9318f2fd6e74112ddcc998ece.tar.gz
libnewt/libnewt-python: upgrade to 0.52.19
- Drop remove_slang_include.patch, libnewt 0.52.19 has fixed it. (From OE-Core rev: 8e24a6ed1cd6fd91f9b4644b1fa199e516c25fa2) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.19.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.19.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.19.bb b/meta/recipes-extended/newt/libnewt_0.52.19.bb
new file mode 100644
index 0000000000..b45461cde3
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.19.bb
@@ -0,0 +1,55 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
21 file://fix_SHAREDDIR.patch \
22 file://cross_ar.patch \
23 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
24 file://pie-flags.patch \
25"
26
27SRC_URI[md5sum] = "e4aa0f7943edd39c52481a87f68f412a"
28SRC_URI[sha256sum] = "08c0db56c21996af6a7cbab99491b774c6c09cef91cd9b03903c84634bff2e80"
29
30S = "${WORKDIR}/newt-${PV}"
31
32EXTRA_OECONF = "--without-tcl --without-python"
33
34inherit autotools-brokensep
35
36CLEANBROKEN = "1"
37
38export STAGING_INCDIR
39export STAGING_LIBDIR
40export CPPFLAGS
41
42PACKAGES_prepend = "whiptail "
43
44do_configure_prepend() {
45 sh autogen.sh
46}
47
48do_compile_prepend() {
49 # Make sure the recompile is OK
50 rm -f ${B}/.depend
51}
52
53FILES_whiptail = "${bindir}/whiptail"
54
55BBCLASSEXTEND = "native"