summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.17.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-06-17 15:01:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 17:56:21 +0100
commitcb25932e731c212d059548bec727917b6d32ece5 (patch)
tree3916e12643810c26d0267b6aa25fca06a3d080a4 /meta/recipes-extended/newt/libnewt_0.52.17.bb
parent55c85889811c769aa841bd74b43294e1f982368f (diff)
downloadpoky-cb25932e731c212d059548bec727917b6d32ece5.tar.gz
libnewt/libnewt-python: upgrade to 0.52.17
- The company address has changed in COPYING. - Rebase fix_SHAREDDIR.patch to 0.52.17 - Rebase cross_ar.patch to 0.52.17 - Obsolete fix_python_fpic.patch, since the patch has been merged by upstream; - The upstream rename snackmodule to snack in 0.52.17, so tweak libnewt-python_0.52.17.bb; (From OE-Core rev: 46ec6e5601b88d4270d58586f25626349474d769) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.17.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.17.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.17.bb b/meta/recipes-extended/newt/libnewt_0.52.17.bb
new file mode 100644
index 0000000000..09b017e24e
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.17.bb
@@ -0,0 +1,49 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20PR = "r2"
21
22SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
23 file://remove_slang_include.patch \
24 file://fix_SHAREDDIR.patch \
25 file://cross_ar.patch \
26"
27
28SRC_URI[md5sum] = "f36d4d908965a0c89fd6fd8b61a6118b"
29SRC_URI[sha256sum] = "69837973ef2ee2fa644426f1c3e48d2b18785ebcd382ef7fd01eb2e67d2d632b"
30
31S = "${WORKDIR}/newt-${PV}"
32
33EXTRA_OECONF = "--without-tcl --without-python"
34
35inherit autotools-brokensep
36
37export STAGING_INCDIR
38export STAGING_LIBDIR
39
40export BUILD_SYS
41export HOST_SYS
42
43PACKAGES_prepend = "whiptail "
44
45do_configure_prepend() {
46 sh autogen.sh
47}
48
49FILES_whiptail = "${bindir}/whiptail"