summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.13.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-07-28 17:28:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-04 15:04:29 +0100
commitdde02ad31e46a7f42cfd0374b3421d52a4b54eaf (patch)
tree2dab8455ea1e939df933c38a6e503d64db5b9c7e /meta/recipes-extended/newt/libnewt_0.52.13.bb
parentc5c9c53c4e736d491d0baf01c94a76099acd4f6f (diff)
downloadpoky-dde02ad31e46a7f42cfd0374b3421d52a4b54eaf.tar.gz
libnewt: update to 0.52.13
Update libnewt to 0.52.13, and remove include-without-python.patch because it has been merged. Update SRC_URI and add SRC_URI checksum. (From OE-Core rev: b83284d2be47019e1ca122ce4a2b1a077e7c3174) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.13.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.13.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.13.bb b/meta/recipes-extended/newt/libnewt_0.52.13.bb
new file mode 100644
index 0000000000..38e09a9f9b
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.13.bb
@@ -0,0 +1,43 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPL"
15LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20PR = "r0"
21
22SRCREV = "c3c7be75f6ef1adfc2be5f99c1e8ef3f0ab58c38"
23
24SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
25 file://remove_slang_include.patch \
26 file://fix_SHAREDDIR.patch"
27
28SRC_URI[md5sum] = "77de05b3f58540152a4ae32a1a64e5d0"
29SRC_URI[sha256sum] = "01c254b00a3d27e22f13240b6db74df04e721ccec4d1d4fc7b45fee009efc05f"
30
31S = "${WORKDIR}/newt-${PV}"
32
33EXTRA_OECONF = "--without-python --without-tcl"
34
35inherit autotools
36
37PACKAGES_prepend = "whiptail "
38
39do_configure_prepend() {
40 sh autogen.sh
41}
42
43FILES_whiptail = "${bindir}/whiptail"