summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.12.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-03-03 12:32:01 +0800
committerSaul Wold <sgw@linux.intel.com>2011-03-03 16:33:58 -0800
commitecbe894712920b42e7b3e645ad554d924d2bbe88 (patch)
treecb649d5d6e4d5dc3e70ec79b63ef918b112c02f7 /meta/recipes-extended/newt/libnewt_0.52.12.bb
parent9a432a2328eb3eec3dbbc87bc697a706095d631d (diff)
downloadpoky-ecbe894712920b42e7b3e645ad554d924d2bbe88.tar.gz
recipe: add newt from OE
newt is a library for text mode user interfaces, and required by chkconfig because of LSB command test. (From OE-Core rev: 57c5da295855431160403b9ea356b2beae5cedca) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.12.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.12.bb b/meta/recipes-extended/newt/libnewt_0.52.12.bb
new file mode 100644
index 0000000000..eefd6bdfd9
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.12.bb
@@ -0,0 +1,37 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPL"
15LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20PR = "r0"
21
22SRCREV = "c3c7be75f6ef1adfc2be5f99c1e8ef3f0ab58c38"
23SRC_URI = "git://git.fedorahosted.org/git/newt;protocol=git \
24 file://include-without-python.patch"
25S = "${WORKDIR}/git"
26
27EXTRA_OECONF = "--without-python --without-tcl"
28
29inherit autotools
30
31PACKAGES_prepend = "whiptail "
32
33do_configure_prepend() {
34 sh autogen.sh
35}
36
37FILES_whiptail = "${bindir}/whiptail"