summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.19.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2016-06-13 05:16:31 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:02 +0100
commit4e5128b5e47315c9318f2fd6e74112ddcc998ece (patch)
tree3c1ce22b7a919334e3c3cef5551355939ab2cd29 /meta/recipes-extended/newt/libnewt-python_0.52.19.bb
parentf81a018089f9b92d08b6a0333c9fb75b9e6824e2 (diff)
downloadpoky-4e5128b5e47315c9318f2fd6e74112ddcc998ece.tar.gz
libnewt/libnewt-python: upgrade to 0.52.19
- Drop remove_slang_include.patch, libnewt 0.52.19 has fixed it. (From OE-Core rev: 8e24a6ed1cd6fd91f9b4644b1fa199e516c25fa2) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.19.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.19.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.19.bb b/meta/recipes-extended/newt/libnewt-python_0.52.19.bb
new file mode 100644
index 0000000000..20369effeb
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.19.bb
@@ -0,0 +1,28 @@
1require recipes-extended/newt/libnewt_${PV}.bb
2
3SUMMARY .= " - python"
4DEPENDS = "libnewt python3"
5RDEPENDS_${PN} += "python3-core"
6
7inherit python3native python3-dir
8
9EXTRA_OECONF += "--with-python"
10EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
11
12
13do_compile () {
14 VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
15 oe_runmake _snack.so
16}
17
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
20 install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
21 install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
22}
23
24PACKAGES_remove = "whiptail"
25
26FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
27
28BBCLASSEXTEND = "native"