summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-25 11:25:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-03 12:23:57 +0000
commitec6aeeada775c032d27f70d47eb5859b3e9bc220 (patch)
tree385877c54c42188e2c0c5e7dd9ba2fb9e024d537 /meta/recipes-extended/newt/libnewt-python_0.52.18.bb
parent4b938a676b59deeac7b62d100c205c06098f4df9 (diff)
downloadpoky-ec6aeeada775c032d27f70d47eb5859b3e9bc220.tar.gz
libnewt/libnewt-python: upgrade to 0.52.18
(From OE-Core rev: 5239060e99da82134387787e544e724500a6ab41) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.18.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.18.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.18.bb b/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
new file mode 100644
index 0000000000..d591fbd3d2
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
@@ -0,0 +1,27 @@
1require recipes-extended/newt/libnewt_${PV}.bb
2
3SUMMARY .= " - python"
4DEPENDS = "libnewt python"
5RDEPENDS_${PN} += "python-core"
6
7inherit pythonnative python-dir
8
9EXTRA_OECONF += "--with-python"
10EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
11
12
13do_compile () {
14 VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
15 oe_runmake "LIBNEWTSH=${STAGING_LIBDIR}/libnewt.so.$VERSION" _snack.so
16}
17
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
20 install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
21 install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
22}
23
24PACKAGES_remove = "whiptail"
25
26FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
27FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"