summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/msmtp/msmtp_1.6.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-17 16:22:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:15 +0000
commitf2192faa59b6bd865e5e19383fb55e09246834cf (patch)
tree3a91fa9a2d5b8f7bf76133df45ea20cd34649407 /meta/recipes-extended/msmtp/msmtp_1.6.3.bb
parent7fc306600553e3fdd9e96626a79b8c71dcf94c4c (diff)
downloadpoky-f2192faa59b6bd865e5e19383fb55e09246834cf.tar.gz
msmtp: update to 1.6.3
(From OE-Core rev: c00293e8b1e8525c7fd1fe6ea3c55cfd51ce0ac3) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/msmtp/msmtp_1.6.3.bb')
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.6.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/msmtp/msmtp_1.6.3.bb b/meta/recipes-extended/msmtp/msmtp_1.6.3.bb
new file mode 100644
index 0000000000..6dbd78f9f6
--- /dev/null
+++ b/meta/recipes-extended/msmtp/msmtp_1.6.3.bb
@@ -0,0 +1,30 @@
1SUMMARY = "msmtp is an SMTP client"
2DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
3HOMEPAGE = "http://msmtp.sourceforge.net/"
4SECTION = "console/network"
5
6LICENSE = "GPLv3"
7DEPENDS = "zlib gnutls"
8
9#COPYING or Licence
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.xz \
13 "
14
15SRC_URI[md5sum] = "6d9384c09405db9476beaa2237c56705"
16SRC_URI[sha256sum] = "f982be069c0772c3ee83925f552f5dac5fb307d2d1c68202f9926bb13b757355"
17
18inherit gettext autotools update-alternatives pkgconfig
19
20EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
21
22ALTERNATIVE_${PN} = "sendmail"
23ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
24ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
25ALTERNATIVE_PRIORITY = "100"
26
27pkg_postinst_${PN}_linuxstdbase () {
28 # /usr/lib/sendmial is required by LSB core test
29 [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
30}