diff options
author | Maxin B. John <maxin.john@intel.com> | 2017-01-13 14:57:09 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-01-19 22:47:21 +0000 |
commit | 17a92e1fb0494d8026219b372af9a28006f9bc53 (patch) | |
tree | 2c700748ebb064c5962a8365628b7070bc602af4 /meta/recipes-extended/mdadm/mdadm_4.0.bb | |
parent | 2068a1e37a7a048ee7b01a7da016009b5e69f620 (diff) | |
download | poky-17a92e1fb0494d8026219b372af9a28006f9bc53.tar.gz |
mdadm: upgrade to version 4.0
3.4 -> 4.0
Removed the following upstreamed or backported patches:
a) 0001-Fix-some-type-comparison-problems.patch
b) 0001-Fix-typo-in-comparision.patch
c) 0001-mdadm.h-bswap-is-already-defined-in-uclibc.patch
d) 0001-raid6check-Fix-if-else-indentation.patch
e) 0001-util.c-include-poll.h-instead-of-sys-poll.h.patch
f) mdadm-3.2.2_fix_for_x32.patch
(From OE-Core rev: b32f5098fc06c96d9331abe0f4ff9cc7c7c08c76)
Signed-off-by: Maxin B. John <maxin.john@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.0.bb')
-rw-r--r-- | meta/recipes-extended/mdadm/mdadm_4.0.bb | 70 |
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.0.bb b/meta/recipes-extended/mdadm/mdadm_4.0.bb new file mode 100644 index 0000000000..c2288995ba --- /dev/null +++ b/meta/recipes-extended/mdadm/mdadm_4.0.bb | |||
@@ -0,0 +1,70 @@ | |||
1 | SUMMARY = "Tool for managing software RAID under Linux" | ||
2 | HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/" | ||
3 | |||
4 | # Some files are GPLv2+ while others are GPLv2. | ||
5 | LICENSE = "GPLv2 & GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
7 | file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \ | ||
8 | file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161" | ||
9 | |||
10 | |||
11 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \ | ||
12 | file://gcc-4.9.patch \ | ||
13 | file://mdadm-3.3.2_x32_abi_time_t.patch \ | ||
14 | file://mdadm-fix-ptest-build-errors.patch \ | ||
15 | file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \ | ||
16 | file://run-ptest \ | ||
17 | file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \ | ||
18 | file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \ | ||
19 | " | ||
20 | SRC_URI[md5sum] = "2cb4feffea9167ba71b5f346a0c0a40d" | ||
21 | SRC_URI[sha256sum] = "1d6ae7f24ced3a0fa7b5613b32f4a589bb4881e3946a5a2c3724056254ada3a9" | ||
22 | |||
23 | CFLAGS += "-fno-strict-aliasing" | ||
24 | inherit autotools-brokensep | ||
25 | |||
26 | EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"' | ||
27 | # PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h | ||
28 | # prevents 64-bit userland from seeing this definition, instead defaulting | ||
29 | # to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get | ||
30 | # int-ll64.h included | ||
31 | CFLAGS_append_powerpc64 = ' -D__SANE_USERSPACE_TYPES__' | ||
32 | CFLAGS_append_mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__' | ||
33 | CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__' | ||
34 | |||
35 | do_compile() { | ||
36 | oe_runmake SYSROOT="${STAGING_DIR_TARGET}" | ||
37 | } | ||
38 | |||
39 | do_install() { | ||
40 | export STRIP="" | ||
41 | autotools_do_install | ||
42 | } | ||
43 | |||
44 | inherit ptest | ||
45 | |||
46 | do_compile_ptest() { | ||
47 | oe_runmake test | ||
48 | } | ||
49 | |||
50 | do_install_ptest() { | ||
51 | cp -a ${S}/tests ${D}${PTEST_PATH}/tests | ||
52 | cp ${S}/test ${D}${PTEST_PATH} | ||
53 | sed -e 's!sleep 0.*!sleep 1!g; s!/var/tmp!/!g' -i ${D}${PTEST_PATH}/test | ||
54 | ln -s /sbin/mdadm ${D}${PTEST_PATH}/mdadm | ||
55 | for prg in test_stripe swap_super raid6check | ||
56 | do | ||
57 | install -D -m 755 $prg ${D}${PTEST_PATH}/ | ||
58 | done | ||
59 | } | ||
60 | RDEPENDS_${PN}-ptest += "bash" | ||
61 | RRECOMMENDS_${PN}-ptest += " \ | ||
62 | coreutils \ | ||
63 | util-linux \ | ||
64 | kernel-module-loop \ | ||
65 | kernel-module-linear \ | ||
66 | kernel-module-raid0 \ | ||
67 | kernel-module-raid1 \ | ||
68 | kernel-module-raid10 \ | ||
69 | kernel-module-raid456 \ | ||
70 | " | ||