summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.3.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/mdadm/mdadm_3.3.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.3.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.bb b/meta/recipes-extended/mdadm/mdadm_3.3.bb
new file mode 100644
index 0000000000..5ef418e170
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Tool for managing software RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3
4# Some files are GPLv2+ while others are GPLv2.
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
8 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
9
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
12 file://mdadm-3.2.2_fix_for_x32.patch \
13 "
14
15SRC_URI[md5sum] = "8ac04259cdd74b4566c3b6dea9414b57"
16SRC_URI[sha256sum] = "9c07e518bdf3392ebac8874eb686258e10ea3ae0ff7a8acb6d014718a9c3ed45"
17
18CFLAGS += "-fno-strict-aliasing"
19
20inherit autotools-brokensep
21
22# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
23do_configure_prepend () {
24 sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
25}
26
27EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
28# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
29# prevents 64-bit userland from seeing this definition, instead defaulting
30# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
31# int-ll64.h included
32EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
33EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
34
35do_compile() {
36 oe_runmake
37}
38
39do_install() {
40 export STRIP=""
41 autotools_do_install
42}
43
44FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"