summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.3.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-10-16 16:40:03 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:59:11 +0100
commit4525157d979867a4e834568180d8f05b46398bea (patch)
tree5fb78d34015b3539adbf2e196688293ddb7b6db8 /meta/recipes-extended/mdadm/mdadm_3.3.bb
parent3347bc49645d2d8623011e3719f68afb9f3f8d90 (diff)
downloadpoky-4525157d979867a4e834568180d8f05b46398bea.tar.gz
mdadm: upgrade to 3.3
Refreshed mdadm-3.2.2_fix_for_x32.patch to apply correctly. (From OE-Core rev: dd125fc30042524079e32027f8be0784f140e379) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.3.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.bb b/meta/recipes-extended/mdadm/mdadm_3.3.bb
new file mode 100644
index 0000000000..23c9408645
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = " A tool for managing Soft RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3BUGTRACKER = "n/a"
4
5# Some files are GPLv2+ while others are GPLv2.
6LICENSE = "GPLv2 & GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
13 file://mdadm-3.2.2_fix_for_x32.patch \
14 "
15
16SRC_URI[md5sum] = "8ac04259cdd74b4566c3b6dea9414b57"
17SRC_URI[sha256sum] = "9c07e518bdf3392ebac8874eb686258e10ea3ae0ff7a8acb6d014718a9c3ed45"
18
19CFLAGS += "-fno-strict-aliasing"
20
21inherit autotools
22
23# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
24do_configure_prepend () {
25 sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
26}
27
28do_compile() {
29 oe_runmake
30}
31
32do_install() {
33 export STRIP=""
34 autotools_do_install
35}
36
37FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"