summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.2.3.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-12-30 14:16:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:37 +0000
commit9b329192ebf30ca8f6bb16e126927c8b4686fb80 (patch)
tree81311afdfb94781f8c0b59f22a2a7a433d92f8ab /meta/recipes-extended/mdadm/mdadm_3.2.3.bb
parenta57cda0f8025d466662bfd0ff3de1984ff01486f (diff)
downloadpoky-9b329192ebf30ca8f6bb16e126927c8b4686fb80.tar.gz
mdadm: upgrade to the latest version 3.2.3
deleted 1 patch since it's in new version now. made LICENSE field more accurate. updated chksum of COPYING: only working change; no actual license change. (From OE-Core rev: f01f6764a744fcb6c5c342ab06a52f97fe362f1a) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.2.3.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.3.bb b/meta/recipes-extended/mdadm/mdadm_3.2.3.bb
new file mode 100644
index 0000000000..17cdd416be
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.3.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = " A tool for managing Soft RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3BUGTRACKER = "n/a"
4
5# Some files are GPLv2+ while others are GPLv2.
6LICENSE = "GPLv2 & GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11PR = "r0"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
14 file://mdadm-3.2.2_fix_for_x32.patch \
15 "
16
17SRC_URI[md5sum] = "d789d6ecb9c1d5ebcc64f0fc52bca92f"
18SRC_URI[sha256sum] = "0ff49a04c6250834ce1b5be5a1581532e70e2221a87e1eedec46d6656b37ab40"
19
20CFLAGS += "-fno-strict-aliasing"
21
22inherit autotools
23
24do_compile() {
25 oe_runmake
26}
27
28do_install() {
29 export STRIP=""
30 autotools_do_install
31}
32
33FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"