summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.2.1.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-04-19 16:22:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-24 22:50:25 +0100
commitd08d8434be0c85fb51f8998a2451d901798039b7 (patch)
tree55c59f4a3b26592486b82ecece81fe49f714390f /meta/recipes-extended/mdadm/mdadm_3.2.1.bb
parente6ca7cc3ed78373bc561b5e0b08bddd31106f102 (diff)
downloadpoky-d08d8434be0c85fb51f8998a2451d901798039b7.tar.gz
mdadm: upgrade from 3.1.4 to the latest version 3.2.1
removed fix-z-now.patch since 3.2.1 has integrated it. (From OE-Core rev: 818b71e7f4190d9fafbbbfa1b68ae1cc99de7c2d) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.2.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.1.bb b/meta/recipes-extended/mdadm/mdadm_3.2.1.bb
new file mode 100644
index 0000000000..937abad845
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.1.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = " A tool for managing Soft RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3BUGTRACKER = "n/a"
4
5#A few files are GPLv2+ while most files are GPLv2.
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11PR = "r0"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2"
14
15SRC_URI[md5sum] = "d1e2549202bd79d9e99f1498d1109530"
16SRC_URI[sha256sum] = "7f68f149c6c0e8893d0b9220ac255b46af08e6a6b81223cab57ed54d628ae125"
17
18CFLAGS += "-fno-strict-aliasing"
19
20inherit autotools
21
22do_compile() {
23 export CROSS_COMPILE="${TARGET_PREFIX}"
24 oe_runmake
25}
26
27do_install() {
28 export STRIP=""
29 autotools_do_install
30}
31