summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.26.bb
diff options
context:
space:
mode:
authorChristian Eggers <ceggers@arri.de>2022-02-16 12:14:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-02 00:22:13 +0000
commit91aa50cdc14d6bb1d97dabceeff74db2b847204a (patch)
tree5fd7e8a73d26f9b4749a438345cd66abbd8c3023 /meta/recipes-extended/mc/mc_4.8.26.bb
parent87ee6c43cee061e785216c96b22f263d97e1ff91 (diff)
downloadpoky-91aa50cdc14d6bb1d97dabceeff74db2b847204a.tar.gz
mc: fix build if ncurses have been configured without wide characters
Some distros like poky-tiny set ENABLE_WIDEC=false, which disables wide character support for ncurses. The new patch fixes the build of mc for this case. Since 9000f8033662, NCURSES_WIDECHAR is set explicitly to 1 for musl. This doesn't work for ENABLE_WIDEC==false. In this case, NCURSES_WIDECHAR must be set explicitly to 0, as curses.h does not record whether the ncurses library has actually been built with or without wide characters. Fixes: 9000f8033662 ("mc: upgrade 4.8.25 -> 4.8.26") (From OE-Core rev: 1d9dbc540a23a77f6ddfbdf34a81a639f2ff82f5) Signed-off-by: Christian Eggers <ceggers@arri.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.26.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.26.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.26.bb b/meta/recipes-extended/mc/mc_4.8.26.bb
index 6bc7e6e8e1..906778400e 100644
--- a/meta/recipes-extended/mc/mc_4.8.26.bb
+++ b/meta/recipes-extended/mc/mc_4.8.26.bb
@@ -12,6 +12,7 @@ SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
12 file://0001-mc-replace-perl-w-with-use-warnings.patch \ 12 file://0001-mc-replace-perl-w-with-use-warnings.patch \
13 file://nomandate.patch \ 13 file://nomandate.patch \
14 file://CVE-2021-36370.patch \ 14 file://CVE-2021-36370.patch \
15 file://0001-Ticket-4200-fix-FTBFS-with-ncurses-build-with-disabl.patch \
15 " 16 "
16SRC_URI[sha256sum] = "9d6358d0a351a455a1410aab57f33b6b48b0fcf31344b9a10b0ff497595979d1" 17SRC_URI[sha256sum] = "9d6358d0a351a455a1410aab57f33b6b48b0fcf31344b9a10b0ff497595979d1"
17 18
@@ -24,7 +25,9 @@ PACKAGECONFIG ??= ""
24PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba," 25PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
25PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2," 26PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
26 27
27CFLAGS_append_libc-musl = ' -DNCURSES_WIDECHAR=1 ' 28# enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config).
29# When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case.
30CFLAGS_append_libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'}"
28EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args" 31EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
29 32
30CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'" 33CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"