summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.25.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-08-23 22:20:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-25 16:00:10 +0100
commit2378ecfd3c8a4a5e55b72c0e2516b9b5bf0a2534 (patch)
tree875ed0957aeecb8791d00d80ccf08750d7aac219 /meta/recipes-extended/mc/mc_4.8.25.bb
parentfd57fa3f2cfdaa6e97f72ca5e248d79ceb10845d (diff)
downloadpoky-2378ecfd3c8a4a5e55b72c0e2516b9b5bf0a2534.tar.gz
mc: upgrade 4.8.24 -> 4.8.25
(From OE-Core rev: a82ee49f8fc0d400f1ba12e0ca80aaeac6bb3523) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.25.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.25.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.25.bb b/meta/recipes-extended/mc/mc_4.8.25.bb
new file mode 100644
index 0000000000..83c8a6ecf6
--- /dev/null
+++ b/meta/recipes-extended/mc/mc_4.8.25.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0 util-linux"
7RDEPENDS_${PN} = "ncurses-terminfo-base"
8RRECOMMENDS_${PN} = "ncurses-terminfo"
9
10SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
11 file://0001-mc-replace-perl-w-with-use-warnings.patch \
12 file://nomandate.patch \
13 "
14SRC_URI[sha256sum] = "407dc20f70082f26c7f5716406cb755cbb6cba3f2f13b841b79a991282d310c2"
15
16inherit autotools gettext pkgconfig
17
18#
19# Both Samba (smb) and sftp require package delivered from meta-openembedded
20#
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
23PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
24
25EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
26
27CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
28CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
29CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
30CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes"
31
32do_install_append () {
33 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
34
35 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
36}
37
38PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
39
40SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
41FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
42 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
43 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
44 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
45 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
46 ${libexecdir}/mc/extfs.d/uzip"
47RDEPENDS_${BPN}-helpers-perl = "perl"
48
49SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
50FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
51
52SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
53FILES_${BPN}-fish = "${libexecdir}/mc/fish"