summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.18.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-04-06 03:05:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-10 23:00:43 +0100
commit7b0a75741376b23d0b1f7e3c04413cc0301b1903 (patch)
tree6d2aae974ac413052a861d6323346c0a5a2130f7 /meta/recipes-extended/mc/mc_4.8.18.bb
parent9356d02da0f761d6694c39224c481cf8850d1469 (diff)
downloadpoky-7b0a75741376b23d0b1f7e3c04413cc0301b1903.tar.gz
mc: replace "perl -w" with "use warnings"
The shebang's max length is usually 128 as defined in /usr/include/linux/binfmts.h: #define BINPRM_BUF_SIZE 128 There would be errors when @PERL@ (hostools/perl) is longer than 128, use '/usr/bin/env perl' can fix the problem, but '/usr/bin/env perl -w' doesn't work: /usr/bin/env: perl -w: No such file or directory So replace "perl -w" with "use warnings" to make it work. (From OE-Core rev: 85decf26fe580acdf072baf561418bf73b7bfca4) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.18.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.18.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.18.bb b/meta/recipes-extended/mc/mc_4.8.18.bb
index 78abb275ba..17f3f73af7 100644
--- a/meta/recipes-extended/mc/mc_4.8.18.bb
+++ b/meta/recipes-extended/mc/mc_4.8.18.bb
@@ -7,6 +7,7 @@ DEPENDS = "ncurses glib-2.0 util-linux"
7RDEPENDS_${PN} = "ncurses-terminfo" 7RDEPENDS_${PN} = "ncurses-terminfo"
8 8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \ 9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
10 file://0001-mc-replace-perl-w-with-use-warnings.patch \
10 " 11 "
11SRC_URI[md5sum] = "cc56f0c9abd63c4caa3636bba3a08bfb" 12SRC_URI[md5sum] = "cc56f0c9abd63c4caa3636bba3a08bfb"
12SRC_URI[sha256sum] = "5b591e10dcbea95233434da40cdad4663d360229adf89826576c319667c103cb" 13SRC_URI[sha256sum] = "5b591e10dcbea95233434da40cdad4663d360229adf89826576c319667c103cb"
@@ -22,6 +23,8 @@ PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
22 23
23EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x" 24EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x"
24 25
26CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
27
25do_install_append () { 28do_install_append () {
26 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/* 29 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
27 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/* 30 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*