summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.18.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-10-23 14:29:48 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:34 +0000
commit39a3763103eb76f8519af2205be6ec7b72940cac (patch)
tree8af850b940b439c7e8c5c10890448c8f86ccc08d /meta/recipes-extended/mc/mc_4.8.18.bb
parent12809c8283b23360e305cad3a8369702a74a41c2 (diff)
downloadpoky-39a3763103eb76f8519af2205be6ec7b72940cac.tar.gz
mc: Upgrade 4.8.17 -> 4.8.18
New release contains bug fixes and refactoring of widget subsystem (From OE-Core rev: c6393ae7790db56b328f9723bcd49429dfbaa119) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.18.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.18.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.18.bb b/meta/recipes-extended/mc/mc_4.8.18.bb
new file mode 100644
index 0000000000..78abb275ba
--- /dev/null
+++ b/meta/recipes-extended/mc/mc_4.8.18.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0 util-linux"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
10 "
11SRC_URI[md5sum] = "cc56f0c9abd63c4caa3636bba3a08bfb"
12SRC_URI[sha256sum] = "5b591e10dcbea95233434da40cdad4663d360229adf89826576c319667c103cb"
13
14inherit autotools gettext pkgconfig
15
16#
17# Both Samba (smb) and sftp require package delivered from meta-openembedded
18#
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
21PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
22
23EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x"
24
25do_install_append () {
26 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
27 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
28}
29
30PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
31
32SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
33FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
34 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
35 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
36 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
37 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
38 ${libexecdir}/mc/extfs.d/uzip"
39RDEPENDS_${BPN}-helpers-perl = "perl"
40
41SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
42FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
43RDEPENDS_${BPN}-helpers-python = "python"
44
45SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
46FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
47
48SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
49FILES_${BPN}-fish = "${libexecdir}/mc/fish"