summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.12.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-extended/mc/mc_4.8.12.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.12.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.12.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.12.bb b/meta/recipes-extended/mc/mc_4.8.12.bb
new file mode 100644
index 0000000000..bc462e3fc0
--- /dev/null
+++ b/meta/recipes-extended/mc/mc_4.8.12.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
10 file://mc-CTRL.patch \
11 "
12
13SRC_URI[md5sum] = "a64c426364bfaee56b628f6c0738aade"
14SRC_URI[sha256sum] = "1054fcc27a488771cbe5b85d7c10135fa1cd1b7682a19930d44b51a023e39396"
15
16inherit autotools gettext pkgconfig
17
18#
19# Both Samba (smb) and sftp require package delivered from meta-openembedded
20#
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
23PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
24
25EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x"
26
27FILES_${PN}-dbg += "${libexecdir}/mc/.debug/"
28
29do_install_append () {
30 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
31 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
32}
33
34PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
35
36SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
37FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
38 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
39 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
40 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
41 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
42 ${libexecdir}/mc/extfs.d/uzip"
43RDEPENDS_${BPN}-helpers-perl = "perl"
44
45SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
46FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
47RDEPENDS_${BPN}-helpers-python = "python"
48
49SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
50FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
51
52SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
53FILES_${BPN}-fish = "${libexecdir}/mc/fish"