summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.10.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/mc/mc_4.8.10.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.10.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.10.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.10.bb b/meta/recipes-extended/mc/mc_4.8.10.bb
new file mode 100644
index 0000000000..511771a1d3
--- /dev/null
+++ b/meta/recipes-extended/mc/mc_4.8.10.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2"
10
11SRC_URI[md5sum] = "eb4bdc23abd4fdfa14911d53d65c8186"
12SRC_URI[sha256sum] = "5f4166fe78fbf4b42f51ed526ca7f79fea8c77d04355c2b97d4df2a6bd2a1b1a"
13
14inherit autotools gettext pkgconfig
15
16EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba"
17
18FILES_${PN}-dbg += "${libexecdir}/mc/.debug/"
19
20do_install_append () {
21 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
22 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
23}
24
25PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
26
27SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
28FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
29 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
30 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
31 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
32 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
33 ${libexecdir}/mc/extfs.d/uzip"
34RDEPENDS_${BPN}-helpers-perl = "perl"
35
36SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
37FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
38RDEPENDS_${BPN}-helpers-python = "python"
39
40SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
41FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
42
43SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
44FILES_${BPN}-fish = "${libexecdir}/mc/fish"