summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man/man_1.6g.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-12-13 19:01:35 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-19 17:55:03 +0000
commitd0505b7c01ac6a5fe4e142b4c2675af553247b29 (patch)
tree0761e8ea3b1023e11c1c37ba1263e54c5acffb3c /meta/recipes-extended/man/man_1.6g.bb
parent3cdf7e2001212a849f90722968dd53d97d7e2061 (diff)
downloadpoky-d0505b7c01ac6a5fe4e142b4c2675af553247b29.tar.gz
man: Update to 1.6g
Rebase some patches (From OE-Core rev: 4cb22ea0beb952a5d70f83aaac415b7f2ecf3fd5) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man/man_1.6g.bb')
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
new file mode 100644
index 0000000000..a2d6acefa6
--- /dev/null
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Online documentation tools"
2DESCRIPTION = "A set of documentation tools: man, apropos and whatis"
3SECTION = "console/utils"
4HOMEPAGE = "http://primates.ximian.com/~flucifredi/man"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
7
8PR = "r0"
9
10DEPENDS = "groff less"
11
12SRC_URI = "http://primates.ximian.com/~flucifredi/${BPN}/${BPN}-${PV}.tar.gz \
13 file://man-1.5k-confpath.patch;striplevel=0 \
14 file://man-1.5h1-make.patch; \
15 file://man-1.5k-nonascii.patch; \
16 file://man-1.6e-security.patch; \
17 file://man-1.6e-mandirs.patch; \
18 file://man-1.5m2-bug11621.patch; \
19 file://man-1.5k-sofix.patch; \
20 file://man-1.5m2-buildroot.patch; \
21 file://man-1.6e-ro_usr.patch; \
22 file://man-1.5i2-newline.patch;striplevel=0 \
23 file://man-1.5j-utf8.patch; \
24 file://man-1.5i2-overflow.patch; \
25 file://man-1.5j-nocache.patch; \
26 file://man-1.5i2-initial.patch; \
27 file://man-1.5h1-gencat.patch;striplevel=0 \
28 file://man-1.5g-nonrootbuild.patch; \
29 file://man-1.5m2-tv_fhs.patch;striplevel=0 \
30 file://man-1.5j-i18n.patch; \
31 file://man-1.6e-whatis2.patch; \
32 file://man-1.6e-use_i18n_vars_in_a_std_way.patch; \
33 file://man-1.5m2-no-color-for-printing.patch; \
34 file://man-1.5m2-sigpipe.patch; \
35 file://man-1.6e-i18n_whatis.patch; \
36 file://man-1.6e-new_sections.patch; \
37 file://man*"
38
39SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"
40SRC_URI[sha256sum] = "ccdcb8c3f4e0080923d7e818f0e4a202db26c46415eaef361387c20995b8959f"
41
42do_configure () {
43 ${S}/configure -default -confdir /etc +sgid +fhs +lang all
44}
45
46
47fakeroot do_install() {
48 oe_runmake install DESTDIR=${D}
49}
50
51do_install_append(){
52 mkdir -p ${D}${sysconfdir}
53 mkdir -p ${D}${datadir}/man/man5
54 mkdir -p ${D}${datadir}/man/man7
55 cp ${WORKDIR}/man.conf ${D}${sysconfdir}/man.config
56 cp ${WORKDIR}/man.1.gz ${D}${datadir}/man/man1/
57 cp ${WORKDIR}/man.7.gz ${D}${datadir}/man/man7/
58 cp ${WORKDIR}/manpath.5.gz ${D}${datadir}/man/man5/
59}
60
61
62RDEPENDS_${PN} = "less groff"
63FILES_${PN} += "${datadir}/locale ${sysconfdir}/man.config"