summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man/man_1.6g.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/man/man_1.6g.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/man/man_1.6g.bb')
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
new file mode 100644
index 0000000000..a66e01cb9a
--- /dev/null
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Online documentation tools"
2DESCRIPTION = "A set of documentation tools: man, apropos and whatis"
3SECTION = "console/utils"
4HOMEPAGE = "http://primates.ximian.com/~flucifredi/man"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
7
8PR = "r1"
9
10DEPENDS = "groff less"
11
12SRC_URI = "http://primates.ximian.com/~flucifredi/${BPN}/${BPN}-${PV}.tar.gz \
13 file://man-1.5k-confpath.patch;striplevel=0 \
14 file://man-1.5h1-make.patch \
15 file://man-1.5k-nonascii.patch \
16 file://man-1.6e-security.patch \
17 file://man-1.6e-mandirs.patch \
18 file://man-1.5m2-bug11621.patch \
19 file://man-1.5k-sofix.patch \
20 file://man-1.5m2-buildroot.patch \
21 file://man-1.6e-ro_usr.patch \
22 file://man-1.5i2-newline.patch;striplevel=0 \
23 file://man-1.5j-utf8.patch \
24 file://man-1.5i2-overflow.patch \
25 file://man-1.5j-nocache.patch \
26 file://man-1.5i2-initial.patch \
27 file://man-1.5h1-gencat.patch;striplevel=0 \
28 file://man-1.5g-nonrootbuild.patch \
29 file://man-1.5m2-tv_fhs.patch;striplevel=0 \
30 file://man-1.5j-i18n.patch \
31 file://man-1.6e-whatis2.patch \
32 file://man-1.6e-use_i18n_vars_in_a_std_way.patch \
33 file://man-1.5m2-no-color-for-printing.patch \
34 file://man-1.5m2-sigpipe.patch \
35 file://man-1.6e-i18n_whatis.patch \
36 file://man-1.6e-new_sections.patch \
37 file://man.1.gz;unpack=false \
38 file://man.7.gz;unpack=false \
39 file://man.conf \
40 file://manpath.5.gz;unpack=false"
41
42SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"
43SRC_URI[sha256sum] = "ccdcb8c3f4e0080923d7e818f0e4a202db26c46415eaef361387c20995b8959f"
44
45do_configure () {
46 ${S}/configure -default -confdir /etc +sgid +fhs +lang all
47}
48
49
50fakeroot do_install() {
51 oe_runmake install DESTDIR=${D}
52}
53
54do_install_append(){
55 mkdir -p ${D}${sysconfdir}
56 mkdir -p ${D}${datadir}/man/man5
57 mkdir -p ${D}${datadir}/man/man7
58 cp ${WORKDIR}/man.conf ${D}${sysconfdir}/man.config
59 cp ${WORKDIR}/man.1.gz ${D}${datadir}/man/man1/
60 cp ${WORKDIR}/man.7.gz ${D}${datadir}/man/man7/
61 cp ${WORKDIR}/manpath.5.gz ${D}${datadir}/man/man5/
62}
63
64
65RDEPENDS_${PN} = "less groff"
66FILES_${PN} += "${datadir}/locale ${sysconfdir}/man.config"