summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man/man_1.6f.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2010-12-29 22:32:25 -0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-30 12:06:52 +0000
commit8494db74786307d44169bee4f21dc0efa1643f70 (patch)
treee98730fc6ed3c971fb5bfd6e8e96b5ef035ddc93 /meta/recipes-extended/man/man_1.6f.bb
parentc0e6d3ea6a819d5f776d861a8336b18cfab5f316 (diff)
downloadpoky-8494db74786307d44169bee4f21dc0efa1643f70.tar.gz
man: updated to 1.6f, fixed patches
Rebased patches for 1.6f: - lzma - modified for xz support - ro_usr & whatis2 fixed up Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/man/man_1.6f.bb')
-rw-r--r--meta/recipes-extended/man/man_1.6f.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man_1.6f.bb b/meta/recipes-extended/man/man_1.6f.bb
new file mode 100644
index 0000000000..f1c9754434
--- /dev/null
+++ b/meta/recipes-extended/man/man_1.6f.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Online documentation tools"
2DESCRIPTION = "A set of documentation tools: man, apropos and whatis"
3SECTION = "console/utils"
4HOMEPAGE = "http://primates.ximian.com/~flucifredi/man"
5PRIORITY = "required"
6LICENSE = "GPLv2"
7PR = "r0"
8
9DEPENDS = "groff less"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
12
13SRC_URI = "http://primates.ximian.com/~flucifredi/${PN}/${PN}-${PV}.tar.gz \
14 file://man-1.5k-confpath.patch;striplevel=0 \
15 file://man-1.5h1-make.patch;striplevel=1 \
16 file://man-1.5k-nonascii.patch;striplevel=1 \
17 file://man-1.6e-security.patch;striplevel=1 \
18 file://man-1.6e-mandirs.patch;striplevel=1 \
19 file://man-1.5m2-bug11621.patch;striplevel=1 \
20 file://man-1.5k-sofix.patch;striplevel=1 \
21 file://man-1.5m2-buildroot.patch;striplevel=1 \
22 file://man-1.6e-ro_usr.patch;striplevel=1 \
23 file://man-1.5i2-newline.patch;striplevel=0 \
24 file://man-1.5j-utf8.patch;striplevel=1 \
25 file://man-1.5i2-overflow.patch;striplevel=1 \
26 file://man-1.5j-nocache.patch;striplevel=1 \
27 file://man-1.5i2-initial.patch;striplevel=1 \
28 file://man-1.5h1-gencat.patch;striplevel=0 \
29 file://man-1.5g-nonrootbuild.patch;striplevel=1 \
30 file://man-1.5m2-tv_fhs.patch;striplevel=0 \
31 file://man-1.5j-i18n.patch;striplevel=1 \
32 file://man-1.6e-whatis2.patch;striplevel=1 \
33 file://man-1.6e-use_i18n_vars_in_a_std_way.patch;striplevel=1 \
34 file://man-1.5m2-no-color-for-printing.patch;striplevel=1 \
35 file://man-1.5m2-sigpipe.patch;striplevel=1 \
36 file://man-1.6e-i18n_whatis.patch;striplevel=1 \
37 file://man-1.6e-new_sections.patch;striplevel=1 \
38 file://man-1.6e-lzma+xz-support.patch;striplevel=1 \
39 file://man*"
40
41SRC_URI[md5sum] = "67aaaa6df35215e812fd7d89472c44b6"
42SRC_URI[sha256sum] = "9f208c7e1981371ad4481d6e6c2c566bc726a15778723f94136d220fb9375f6c"
43
44
45do_configure () {
46 ${S}/configure -default -confdir ${D}/etc +sgid +fhs +lang all
47}
48
49
50fakeroot do_install() {
51 oe_runmake install DESTDIR=${D}
52}
53
54do_install_append(){
55 mkdir -p ${D}/etc/
56 mkdir -p ${D}${datadir}/man/man5
57 mkdir -p ${D}${datadir}/man/man7
58 cp ${S}/src/man.conf ${D}/etc/
59 cp ${WORKDIR}/man.1.gz ${D}${datadir}/man/man1/
60 cp ${WORKDIR}/man.7.gz ${D}${datadir}/man/man7/
61 cp ${WORKDIR}/manpath.5.gz ${D}${datadir}/man/man5/
62}
63
64
65FILES_${PN} += "${datadir}/locale"